Bug 1737392 - oc new-build --help should not have some flags in the help text
Summary: oc new-build --help should not have some flags in the help text
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.3.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-05 09:49 UTC by Saurabh Sadhale
Modified: 2020-02-24 08:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: oc new-build wasn't properly filtering flags displayed in help message. Consequence: The unnecessary flags were being printed when invoking oc new-build --help. Fix: Filter out flags that do not apply to oc new-build command. Result: The output of --help reflects its usage.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:05:01 UTC
Target Upstream Version:
maszulik: needinfo-
maszulik: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 44 'None' closed Bug 1737392: Hide sort-by flag from new-build help 2020-03-09 11:40:49 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:05:16 UTC

Comment 1 Maciej Szulik 2019-08-06 13:42:03 UTC
I've fixed the sort-by flag in https://github.com/openshift/oc/pull/44 but the remaining two are coming from printer flags.
I'll need to have a one more look, though.

Comment 8 Maciej Szulik 2019-10-14 13:25:41 UTC
Checked against 4.3.0-0.ci-2019-10-14-031716 and it's working as expected.

Comment 10 zhou ying 2019-10-15 08:00:29 UTC
Confirmed with latest oc client, the issue has fixed:

oc version: 4.3.0-201910141917.git.1.7327846.el7

`oc new-build --help`  couldn't have the sort-by flag now.

Comment 17 errata-xmlrpc 2020-01-23 11:05:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.