Bug 173742 - Latest plt-scheme build lost Xft/fontconfig support
Latest plt-scheme build lost Xft/fontconfig support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plt-scheme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 05:14 EST by Anders Kaseorg
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: plt-scheme-300-3.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 21:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Kaseorg 2005-11-20 05:14:19 EST
Description of problem:
Between plt-scheme 299.200-10 and 299.200-15, antialiased fonts disappeared from
drscheme. Comparing the output of `ldd /usr/bin/mred`, the binary is no longer
linked against libXft, libfreetype, or libfontconfig.

Version-Release number of selected component (if applicable):
plt-scheme-299.200-15
Comment 1 Gérard Milmeister 2005-11-20 15:50:55 EST
I noticed this. It is probably due to the new modular xorg.
The configure script reports the following:

checking X11/Xft/Xft.h usability... no
checking X11/Xft/Xft.h presence... no
checking for X11/Xft/Xft.h... no
no Xft headers; Xft support disabled

I cannot investigate this on devel, maybe you could
try and locate the problem.
Comment 2 Anders Kaseorg 2005-11-20 17:50:24 EST
Found the problem, and submitted a bug report upstream:
  <http://bugs.plt-scheme.org/query/?cmd=view&pr=7691>
Basically, the configure script tries xft-config but not pkg-config xft, so it
can't find the freetype headers that Xft.h needs.
Comment 3 Gérard Milmeister 2005-11-20 19:31:30 EST
Thanks for the help. I made a patch for configure to use pkg-config instead
of xft-config. A build is in the making, and as far as I can see this 
should be working now.
Comment 4 Anders Kaseorg 2005-11-22 20:38:06 EST
Yes, Xft works in 299.200-17.fc5. Also, the upstream bug has been fixed on the
trunk.

By the way, why does the spec file increase the default font size?
  # increase default font size
  sed -i -e "s|fsize = 10|fsize = 12|" wxxt/src/Application/AppMain.cc
The 12 point font is really huge compared to other applications.
Comment 5 Gérard Milmeister 2005-11-23 05:56:28 EST
(In reply to comment #4)
> The 12 point font is really huge compared to other applications.
What dpi setting are you using? I have currently 90x89 on one
machine and 75x75 on another one. Font size 10 is quite small
and 12 is just right. The font size of Tk apps for example is
12 per default, so this seems to be adequate. 
Comment 6 Anders Kaseorg 2005-11-25 19:14:15 EST
By default, Fedora forces Xft to 96 dpi (/etc/X11/Xresources) and uses 10-point
fonts in GTK2 and Qt apps. (Tk does not use Xft, so it has an entirely different
idea of what a "12-point font" is.) I see no reason to go against both upstream
and Fedora defaults just to suit one particular customized system.
Comment 7 Gérard Milmeister 2005-11-26 06:04:04 EST
Ok, you are right. I removed the patch and made a build for the
new version 299.400.
Comment 8 Anders Kaseorg 2005-12-23 01:47:01 EST
Xft is gone again from 300-2.fc5. However, it returns if I build the SRPM on my
system. I haven't seen the extras build logs, but I have a wild
guess--BuildRequires: pkgconfig?

BTW, can cairo support be enabled on FC5? It gets enabled by default if
cairo-devel is installed.
Comment 9 Gérard Milmeister 2005-12-23 04:22:01 EST
Here is the extract from the build log:

checking X11/extensions/Xrender.h usability... yes
checking X11/extensions/Xrender.h presence... yes
checking for X11/extensions/Xrender.h... yes
checking for XRenderQueryExtension in -lXrender... yes
checking X11/Xft/Xft.h usability... no
checking X11/Xft/Xft.h presence... no
checking for X11/Xft/Xft.h... no
no Xft headers; Xft support disabled
no information from pkg-config; Cairo support disabled

I have no fc5 to try the builds on. I would be glad if you
helped with this.
Comment 10 Michael Schwendt 2005-12-31 12:30:44 EST
BuildRequires: pkgconfig cairo-devel
Comment 11 Gérard Milmeister 2006-01-02 18:34:42 EST
Just made a new build.
Please check when released.
Comment 12 Anders Kaseorg 2006-01-03 21:08:48 EST
Works. Thanks.

Note You need to log in before you can comment on or make changes to this bug.