Bug 173748 - fig2dev still refers to /usr/X11R6/lib/X11/rgb.txt
Summary: fig2dev still refers to /usr/X11R6/lib/X11/rgb.txt
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: transfig   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-20 16:01 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 08:47:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2005-11-20 16:01:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; en_US) KHTML/3.5.0 (like Gecko)

Description of problem:
There is still a dependence on X11R6 in fig2dev, which seems hard to get rid of. 
Recompiling does not do it, at least with the current imake. Current imake is not 
exactly fixed for modular X and is not used/supported by X anymore. I had to 
patch it by hand to achieve this. 
 
Another problem to watch for is the fact that rgb.txt is in /usr/lib/X11/rgb.txt 
on i386 systems BUT is on /usr/lib64/X11/rgb.txt on x86_64. 
 
I hope there is an easy fix. 
Thanks 

Version-Release number of selected component (if applicable):
transfig-3.2.4-12

How reproducible:
Always

Steps to Reproduce:
1. do "strings /usr/bin/fig2dev | grep R6" 
2. Look at the location of the rgb.txt file 
3. 
   

Additional info:

Comment 1 Sammy 2005-11-21 00:00:47 UTC
It looks like tomorrow this location is changing to /usr/share/X11/rgb.txt  

Comment 2 Ngo Than 2006-05-16 08:47:56 UTC
it's now fixed in 3.2.4-14. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.