Bug 1737526 - [4.1.z] Should gracefully exit when try to delete configs.imageregistry.operator.openshift.io
Summary: [4.1.z] Should gracefully exit when try to delete configs.imageregistry.opera...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Corey Daley
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On: 1711173
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-05 15:15 UTC by Adam Kaplan
Modified: 2019-08-15 14:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1711173
Environment:
Last Closed: 2019-08-15 14:24:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2417 None None None 2019-08-15 14:24:25 UTC
Github openshift cluster-image-registry-operator pull 351 None None None 2019-08-05 15:28:03 UTC

Description Adam Kaplan 2019-08-05 15:15:20 UTC
+++ This bug was initially created as a clone of Bug #1711173 +++

Description of problem:
Should not just hang there if try to delete configs.imageregistry.operator.openshift.io since bucket is not empty according to clusteroperator status.

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-16-223922

How reproducible:
Always

Steps to Reproduce:
1.$ oc delete configs.imageregistry.operator.openshift.io cluster
2.
3.

Actual results:
The command just hang there until user delete bucket in S3 console.

Expected results:
Should warning cannot delete since bucket is not empty.

Additional info:
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-05-17T06:52:19Z
    Message:               The registry is ready
    Reason:                Ready
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-05-17T07:05:29Z
    Message:               The registry is being removed
    Reason:                Removing
    Status:                True
    Type:                  Progressing
    Last Transition Time:  2019-05-17T07:05:29Z
    Message:               Unable to remove registry: unable to remove storage: BucketNotEmpty: The bucket you tried to delete is not empty
                           status code: 409, request id: 96FCA0A86CD1C234, host id: a/AQlE2VrOtlAOoIqbZdue4iqyu01776Ceynb0yum7vHLH9ID0/l/V2ula/jranluAMv8e94d5c=, BucketNotEmpty: The bucket you tried to delete is not empty
                           status code: 409, request id: 96FCA0A86CD1C234, host id: a/AQlE2VrOtlAOoIqbZdue4iqyu01776Ceynb0yum7vHLH9ID0/l/V2ula/jranluAMv8e94d5c=
    Reason:                RemoveFailed
    Status:                True
    Type:                  Degraded

--- Additional comment from Adam Kaplan on 2019-05-17 15:32:30 UTC ---

Targeting 4.2.0. We will likely want to backport the fix to 4.1.z as well.

--- Additional comment from Wenjing Zheng on 2019-08-01 08:45:55 UTC ---

Verified on 4.2.0-0.nightly-2019-08-01-035705:
[wzheng@openshift-qe 4.2]$ oc delete configs.imageregistry.operator.openshift.io cluster
config.imageregistry.operator.openshift.io "cluster" deleted
[wzheng@openshift-qe 4.2]$ oc get crd | grep registry
configs.imageregistry.operator.openshift.io                 2019-08-01T02:46:51Z

Comment 3 Wenjing Zheng 2019-08-07 06:21:27 UTC
Verified on 4.1.0-0.nightly-2019-08-06-212225.

Comment 5 errata-xmlrpc 2019-08-15 14:24:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2417


Note You need to log in before you can comment on or make changes to this bug.