Bug 173754 - forward flag is not working in recent fedora versions
forward flag is not working in recent fedora versions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oidentd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 11:48 EST by Vilius Šumskas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 06:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vilius Šumskas 2005-11-20 11:48:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
Forward to masquaraded clients is not working in recent Fedora versions.

Version-Release number of selected component (if applicable):
oidentd-2.0.7-7

How reproducible:
Always

Steps to Reproduce:
1. set values in oidentd.users file.
2. run oidentd with flags -f -m.

  

Actual Results:  All masquaraded clients did not recieve identd information.

Additional info:

If you manually add some rules in iptables to DNAT/FORWARD identd port (113) to some particular clients they work perfectly.
Comment 1 Matthias Saou 2005-11-22 06:35:56 EST
Was this working with older Fedora Core releases and the same oidentd version?
Do you have any idea what might have caused this?
Comment 2 Vilius Šumskas 2005-11-22 12:48:15 EST
I don't know for sure. I tried to use it on FC2 and failed too. But I remember 
on RedHat8 (or maybe it was 9) it worked.

As I'm not expert in Linux internals, I have no idea what could cause the 
problem. I think it might be related to core things, such as 
kernel/iptables/glibc.

If you need me to run strace or similar things in my environment, I'll will 
gladly help. However, I saw this faulty behaviour on other servers too, so you 
couldn't find trouble reproducing it.
Comment 3 Vilius Šumskas 2006-06-28 15:20:46 EDT
Finally! It seems that this was fixed in new 2.0.8 version. I compiled 2.0.8 
on fedora5 and everything works as expected.

The problem was that conntrack file format changed in linux 2.6.9.

Please rebuild rpm with new version.
Comment 5 Matthias Saou 2006-06-29 06:21:37 EDT
Thanks a lot for all those details! I've just rebuilt 2.0.8 packages for FC-5
and devel, improving a few other details too :
- Update to 2.0.8 which fixes bugzilla #173754.
- Don't flag init script as %%config.
- Rename init script "identd" -> "oidentd", remove pidentd conflict and add
  update scriplet special case when upgrading from the "identd" service.
- Move options into a sysconfig file.

Note You need to log in before you can comment on or make changes to this bug.