Bug 1737672 - [machines] There will be an error if checking 'Immediately Start VM' in creation of VM
Summary: [machines] There will be an error if checking 'Immediately Start VM' in creat...
Keywords:
Status: CLOSED DUPLICATE of bug 1724287
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit-appstream
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Katerina Koukiou
QA Contact: YunmingYang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-06 02:37 UTC by YunmingYang
Modified: 2019-08-06 10:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 10:25:34 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description YunmingYang 2019-08-06 02:37:26 UTC
Description of problem:
If checking 'Immediately Start VM', the vm will be created successfully and run correctly, but there is an error raised, which is 'Creation of VM ${vm_name} failed'

Version-Release number of selected component (if applicable):
cockpit-machines-197.1-1.el8.noarch
libvirt-dbus-1.2.0-2.module+el8.1.0+2983+b2ae9c0a.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Open the VM creation dialog
2. Connection: QEMU/KVM System connection
   Installation Source Type: URL
   Installation Source: url which is https and ostree
   Immediately Start VM: check

Actual results:
The vm runs correctly but there is an error which is 'Creation of VM ${vm_name} failed' raised.

Expected results:
The vm runs correctly and there is no error raised.

Additional info:
There is also a message shown on the console of browser:
The vm runs correctly but there is an error which is 'Creation of VM ${vm_name} failed' raised.

if set '--wait 0 --noreboot' for virt-install, $? in fedora is 0, in RHEL8 is 1

Comment 1 Katerina Koukiou 2019-08-06 08:37:42 UTC
This looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1724287
I wonder why you see it though still, since virt-install 2.2.1 includes the fix and is in available in RHEL8.
Can you check the virt-install version in the machine that you verified this?

In addition since cockpit-199 we don't use wait=0, but this release is not available in RHEL8 indeed.

See:

commit 1d686a1ca44dffaf3261e90f85ce2035ae0a54ad
Author: Katerina Koukiou <kkoukiou@redhat.com>
Date:   Thu Jun 27 18:23:51 2019 +0200

    machines: bring back machine wait=-1 noreboot options on virt-install in the VM creation

Comment 2 YunmingYang 2019-08-06 09:42:14 UTC
Here is the version:
# rpm -qa | grep virt-manager
virt-manager-common-2.2.0-1.el8.noarch

So the bug is because of the lower version of virt-manager. It is also because of the old compose, the new version of virt-manager is not added. So should we just leave the bug here so that i can check it
in next compose?

Comment 3 Katerina Koukiou 2019-08-06 10:25:34 UTC

*** This bug has been marked as a duplicate of bug 1724287 ***


Note You need to log in before you can comment on or make changes to this bug.