Bug 173771 - Update gcc to 4.0.2 on FC4 for scipy
Update gcc to 4.0.2 on FC4 for scipy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 173258 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 16:59 EST by Ravikiran Rajagopal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.2-8.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 16:38:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravikiran Rajagopal 2005-11-20 16:59:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.3 (like Gecko)

Description of problem:
In order to compile SciPy (preferably from SVN, but even the old released 
0.3.2 package), d1mach.f needs to be compiled correctly. However, the gfortran 
compiler shipped with gcc-4.0.1-4 does not compile it correctly. This is a 
known gcc bug (18518) fixed in gcc-4_0-branch. Other issues (such as incorrect 
code generation with -msse2) which ease compilation are also fixed in the 
branch above.  
The version of gcc in rawhide (4.0.2-6) fixes all these issues and is 
perfectly suitable for building SciPy. However, it requires versions of 
binutils, libtool, and glibc that are not available for FC4. Could we have a 
port of the rawhide version to FC4? 
In order to make 4.0.2-6 work with the current glibc (2.3.5-10.3) and binutils 
(2.15.94.0.2.2-2.1) on i386, I used the source rpm from Rawhide to build my 
own package with everything but the weakref patch. My understanding is that 
the updated binutils is required only on PPC, and weakref support is the only 
patch that requires the updated glibc. With the binaries built from 4.0.2-6 
without the weakref patch, SciPy compiles fine and passes all but one (corner 
case) test. However, the new gcc binary fails during compilation of ATLAS. I 
believe this may be because I need to update binutils (not an option at this 
time). Hence, the easiest route is to obtain at least an SRPM of 4.0.2-6 that 
can be used with FC4. Others have requested this on the lists as well: 
http://www.redhat.com/archives/fedora-extras-list/2005-October/msg00999.html 
 

Version-Release number of selected component (if applicable):
gcc-4.0.1-4

How reproducible:
Always

Steps to Reproduce:
1. Obtain SVN code from www.scipy.org (scipy and scipy_core) 
2. Compile and install 
3. python -c "import scipy; scipy.test(10,10)" 
   

Actual Results:  Segmentation fault in check_dot. 

Expected Results:  All tests should pass. 

Additional info:

To obtain and build scipy, please see the following URLs: 
http://www.scipy.org/mailinglists/mailman?fn=scipy-dev/2005-November/004018.html 
Then run: 
python setup.py config_fc --fcompiler=gnu95 build 
on the two repositories checked out.
Comment 1 Jakub Jelinek 2005-11-21 04:18:37 EST
*** Bug 173258 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2005-11-21 15:29:37 EST
gcc-4.0.2-7.fc4 is in fc4 testing updates.  Please test it as much as possible.
Comment 3 Ravikiran Rajagopal 2005-11-21 17:19:22 EST
Currently testing it. Will try ATLAS, all of KDE, lapack and SciPy. Note that 
this breaks libtool on FC4 which will need recompilation since it depends on 
the exact compiler version. I am building my own, but you will need to do so 
for others. 
 
Comment 4 Ravikiran Rajagopal 2005-11-28 14:04:41 EST
Everything seems to be fine. I have not seen any problems with my usage of the 
software recompiled with the new gcc. 

Note You need to log in before you can comment on or make changes to this bug.