Bug 173774 - bash completion for plague-client
bash completion for plague-client
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: plague (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 17:18 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 15:54:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bash_completion support for plague-client (1.58 KB, patch)
2005-11-20 17:18 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-11-20 17:18:13 EST
Attached is a patch that adds bash_completion support for plague-client.
Comment 1 Ville Skyttä 2005-11-20 17:18:14 EST
Created attachment 121283 [details]
bash_completion support for plague-client
Comment 2 Ville Skyttä 2005-11-26 15:54:31 EST
Nevermind, there seems to be resistance elsewhere adding these snippets to 
corresponding packages, so I'll ship them all in the bash-completion package 
at least for now. 
Comment 3 Dan Williams 2005-11-27 00:43:55 EST
Not that I wouldn't have added them...  I was just preoccupied with the depsolve
stuff and hadn't gotten around to it.  So bash completion stuff has to live in
its own package?
Comment 4 Ville Skyttä 2005-11-27 04:27:08 EST
This stuff can live in either the bash-completion package or the package that 
it provides completions for. 
 
The advantage of the former is that it doesn't "clutter" other packages, and 
the advantage of the latter is that I believe it would be more likely to be up 
to date with the thing it provides completions for and would match the options 
of the actually installed version of the package (assuming, of course, that it 
will be kept up to date when options are added/removed/changed). 
 
I'm prepared to have this in the bash-completion package, but if you think 
it's ok to have it in plague-client, just go ahead and apply it and let me 
know and I won't ship a conflicting one in bash-completion. 

Note You need to log in before you can comment on or make changes to this bug.