Bug 173776 - kdm calls /usr/X11R6/bin/X to start X
kdm calls /usr/X11R6/bin/X to start X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 18:01 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 09:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-11-20 18:01:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; en_US) KHTML/3.5.0 (like Gecko)

Description of problem:
kdm calls /usr/X11R6/bin/X to start the X server which no longer exists and it 
should be /usr/bin/X instead. You may be able to fix this but I found it to be 
difficult since configure seems to use imake and imake still refers to old paths. 
I filed this with Mike Harris too but the general idea is not to use imake any more 
since X itself does not use it. Perhaps you can path something in the configure 
script to change it instead. I  changed bunch of things in *.cf *.tmpl files for imake 
and got it to finally pick the right path. Otherwise system hangs for people trying 
to reboot with kdm. 

Version-Release number of selected component (if applicable):
kdebase-0.

How reproducible:
Always

Steps to Reproduce:
1. Do "strings /usr/bin/kdm | grep R6" 
2. or restart kdm after installing modular X 
3. 
   

Additional info:
Comment 1 Mogens Kjaer 2005-11-25 07:39:04 EST
This is also the case in FC5test1.

mkdir /usr/X11R6/bin
ln -s /usr/bin/X /usr/X11R6/bin/X

is a quick-and-dirty workaround.

I need kdm as a workaround for bug 113153...
Comment 2 Ville Skyttä 2006-01-10 17:00:42 EST
The proper fix AFAIK is to bring kdmrc up to date, see bug 166388.
Comment 3 Ngo Than 2006-02-14 09:38:57 EST
this problem has been fixed in the rawhide. Thanks for your report 

Note You need to log in before you can comment on or make changes to this bug.