Bug 1737796 - wine-4.13 is not packaged correctly, causing installation or upgrade to fail
Summary: wine-4.13 is not packaged correctly, causing installation or upgrade to fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-06 09:00 UTC by hx
Modified: 2019-08-20 02:04 UTC (History)
4 users (show)

Fixed In Version: wine-4.13-3.fc30 wine-4.13-5.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-09 01:03:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Wine HQ 46645 0 None None None 2019-08-06 09:00:08 UTC
Wine HQ 47579 0 None None None 2019-08-06 09:00:08 UTC

Description hx 2019-08-06 09:00:08 UTC
Description of problem: Installation or Upgrade is complete while internal scripts fails.


Version-Release number of selected component (if applicable): 4.13


How reproducible: Easily on Fedora 30 by installing or upgrading from previous version.


Steps to Reproduce:
1. open terminal
2. run 'sudo dnf install 'wine' --refresh --enablerepo=updates-testing'
3. try running nay DirectX9 application. As result, the various errors are spawned, ultimately saying that there is no DirectX9 installed in Wine prefix.

Actual results:
Installation is successful, but with unusable DirectX9.

Expected results:
Installation is successful and no functionality degradation is present.

Additional info:
See external bug links.

Comment 1 Joachim Backes 2019-08-06 09:22:27 UTC
Same here:
 (reproducing point 2)

  Running scriptlet: wine-core-4.13-1.fc30.i686                                                                                         70/70 
the primary link for wine-dxgi must be /usr/lib64/wine/dxgi.dll.so
the primary link for wine-d3d9 must be /usr/lib64/wine/d3d9.dll
the primary link for wine-d3d10 must be /usr/lib64/wine/d3d10.dll
the primary link for wine-d3d11 must be /usr/lib64/wine/d3d11.d
ffwarning: %posttrans(wine-core-4.13-1.fc30.i686) scriptlet failed, exit status 2

Comment 2 Benjamin 2019-08-06 10:28:56 UTC
This works in 4.13-2.

Comment 3 hx 2019-08-06 10:57:05 UTC
Great. So far build is done only for FC31, so possibly only by end of this week usable build will be there in bodhi and in testing repos.

Comment 4 Benjamin 2019-08-06 16:38:12 UTC
The build is completed in koji, it just isn't yet in bodhi. I posted to the bodhi page:

"wine-core will install with sudo dnf install https://kojipkgs.fedoraproject.org//packages/wine/4.13/2.fc30/x86_64/wine-core-4.13-2.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/wine/4.13/2.fc30/i686/wine-core-4.13-2.fc30.i686.rpm https://kojipkgs.fedoraproject.org//packages/wine/4.13/2.fc30/noarch/wine-filesystem-4.13-2.fc30.noarch.rpm. Dependency issues mean that this will only work if wine isn't already installed, or the entire set of rpm files are manually specified on the commandline. You can do this for testing.

All the directx files that weren't installing before are now there. I don't recommend actually doing this (an entire wine installation specified manually on the commandline), but 4.13-2 should work."

I know that it can work because the build is done, even if practically unavailable.

Comment 5 Fedora Update System 2019-08-07 15:03:58 UTC
FEDORA-2019-d4654d4a25 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4654d4a25

Comment 6 Fedora Update System 2019-08-07 15:04:00 UTC
FEDORA-2019-d4654d4a25 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4654d4a25

Comment 7 Fedora Update System 2019-08-07 15:13:34 UTC
FEDORA-2019-891ad3389e has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 8 Fedora Update System 2019-08-07 15:13:35 UTC
FEDORA-2019-891ad3389e has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 9 Fedora Update System 2019-08-08 01:36:40 UTC
FAudio-19.08-1.fc30, wine-4.13-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4654d4a25

Comment 10 Fedora Update System 2019-08-08 02:56:37 UTC
FAudio-19.08-1.fc29, wine-4.13-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 11 Fedora Update System 2019-08-09 01:03:15 UTC
FAudio-19.08-1.fc30, wine-4.13-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-08-09 04:17:52 UTC
FEDORA-2019-891ad3389e has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 13 Fedora Update System 2019-08-11 01:22:34 UTC
FAudio-19.08-1.fc29, wine-4.13-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 14 Fedora Update System 2019-08-11 17:14:49 UTC
FEDORA-2019-891ad3389e has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 15 Fedora Update System 2019-08-12 03:00:34 UTC
FAudio-19.08-1.fc29, wine-4.13-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-891ad3389e

Comment 16 Fedora Update System 2019-08-20 02:04:11 UTC
FAudio-19.08-1.fc29, wine-4.13-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.