Bug 1737802 - [IPI] [OSP] Delete swift container containing ignition files after cluster is initialized
Summary: [IPI] [OSP] Delete swift container containing ignition files after cluster is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.2.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-06 09:10 UTC by David Sanz
Modified: 2019-10-16 06:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2259 None None None 2019-08-23 11:41:47 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:35:01 UTC

Description David Sanz 2019-08-06 09:10:30 UTC
Description of problem:

After installing a cluster on OSP, swift container created to expose ignition files remains created. As it is not going to be used anymore, it should be deleted after cluster is correctly installed


Version-Release number of the following components:
4.2.0-0.nightly-2019-08-06-062019

How reproducible:

Steps to Reproduce:
1.Install ipi on osp
2.Go to Object "Storage > Containers" tab
3.Find container associated to your cluster (it contains cluster-name in its name)

Actual results:
Swift container remains created and it is only deleted when cluster is deleted.

Expected results:
As it is not going to be used anymore after cluster is installed, it should be deleted

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Eric Duen 2019-08-15 15:46:54 UTC
Mike, can you take a look.

Comment 2 Dan Prince 2019-08-16 12:47:56 UTC
I think the ignition files would be required any time you want to expand/scale the cluster. As such this may be considered not a bug.

Comment 3 Mike Fedosin 2019-08-16 21:52:09 UTC
Agree with Dan, we need the ignition files after the installation if we want to add new machines.

Comment 4 Mike Fedosin 2019-08-23 11:42:30 UTC
Fix is on review: https://github.com/openshift/installer/pull/2259

Comment 6 David Sanz 2019-08-27 07:46:20 UTC
Verified on 4.2.0-0.nightly-2019-08-27-061931

When bootstrap node is deleted, swift container is also removed

Comment 7 errata-xmlrpc 2019-10-16 06:34:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.