Bug 173784 - Lame if statement in /etc/profile
Lame if statement in /etc/profile
Status: CLOSED DUPLICATE of bug 160731
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
N/A
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 00:18 EST by Anton Solovyev
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 12:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Solovyev 2005-11-21 00:18:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
When Bourne shells other than bash are used (/bin/ksh for example) environment variable "EUID" is not set. An if statement in /etc/profile does not account for this possibility and test fails with syntax error.

Here is what it is now:

===
if [ $EUID = 0 ]; then

===

here is what it should be:

===
if [ "${EUID}X" = "0X" ]; then
===


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set your shell to /bin/ksh
2. Login
3. Observe the error message
  

Actual Results:  See above

Additional info:
Comment 1 Bill Nottingham 2005-11-21 12:20:21 EST

*** This bug has been marked as a duplicate of 160731 ***

Note You need to log in before you can comment on or make changes to this bug.