Bug 1737884 - spausedd does not detect VMGuestLib
Summary: spausedd does not detect VMGuestLib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync
Version: 7.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1740181
TreeView+ depends on / blocked
 
Reported: 2019-08-06 10:38 UTC by Miroslav Lisik
Modified: 2020-09-04 18:59 UTC (History)
7 users (show)

Fixed In Version: corosync-2.4.5-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1738218 1740181 (view as bug list)
Environment:
Last Closed: 2020-03-31 19:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1217663 0 None None None 2019-08-07 16:56:16 UTC
Red Hat Knowledge Base (Solution) 4340901 0 None None None 2020-09-04 18:59:54 UTC
Red Hat Product Errata RHBA-2020:1079 0 None None None 2020-03-31 19:54:37 UTC

Internal Links: 1542703

Description Miroslav Lisik 2019-08-06 10:38:20 UTC
Description of problem:

Daemon spausedd does not detect VMGuestLib and consequently does not set appropriate default for 'steal_threshold'.

From man spausedd(8):

 -t steal_threshold
             Set steal threshold percent. (default is 10 if kernel information is used and 100 if VMGuestLib is used).


Version-Release number of selected component (if applicable):
corosync-2.4.3-6.el7
spausedd-2.4.3-6.el7

How reproducible:
always on VMware platform

Steps to Reproduce:

1.1. Start spausedd
# systemctl start spausedd
2. check log messages



Actual results:
Aug  6 06:18:10 vmw600-node4-rhha spausedd[27578]: Running main poll loop with maximum timeout 200 and steal threshold 10%

Expected results:
threshold 100% on VMware


Additional info:

From discussion with developer it seems it is a problem with package compilation.

Comment 1 Jan Friesse 2019-08-06 11:32:44 UTC
Proposed change in corosync.spec file:

@@ -178,13 +178,14 @@ make %{_smp_mflags}
 
 %if %{with spausedd}
 cd spausedd-%{spausedd_version}
+CFLAGS="${CFLAGS:-%{optflags}}" ; export CFLAGS
 make \
 %if %{defined use_vmguestlib}
     WITH_VMGUESTLIB=1 \
 %else
     WITH_VMGUESTLIB=0 \
 %endif
-    %{?_smp_mflags} CFLAGS="%{optflags}"
+    %{?_smp_mflags}
 %endif
 
 %install

Comment 2 Jan Friesse 2019-08-06 14:51:57 UTC
@John, @Shane, @Cole:
Chris told me that you are able to decide (and GSS approve this bug) if 7.7.z for this bug is needed or not. Let me shortly summarize what does and what doesn't work without this patch:

Does work:
- Spausedd is able to detect pause
- It is also able to detect length of pause
- It should be able to tell if problem is because of overloaded hypervisor for hypervisors where kernel way of getting steal time is supported (KVM)

Doesn't work:
- Spausedd is not able to tell if problem is because of overloaded hypervisor for VMware hypervisor

Comment 11 errata-xmlrpc 2020-03-31 19:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1079


Note You need to log in before you can comment on or make changes to this bug.