Bug 1737887 - Remove executable bit from file /usr/lib/systemd/system/spausedd.service
Summary: Remove executable bit from file /usr/lib/systemd/system/spausedd.service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-06 10:46 UTC by Miroslav Lisik
Modified: 2020-03-31 19:54 UTC (History)
3 users (show)

Fixed In Version: corosync-2.4.5-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-31 19:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1079 0 None None None 2020-03-31 19:54:37 UTC

Description Miroslav Lisik 2019-08-06 10:46:29 UTC
Description of problem:

Systemd does not like executable bit for file /usr/lib/systemd/system/spausedd.service.

From logs:
Aug  6 04:46:15 vmw600-node4-rhha systemd: Configuration file /usr/lib/systemd/system/spausedd.service is marked executable. Please remove executable permission bits. Proceeding anyway.


Version-Release number of selected component (if applicable):
corosync-2.4.3-6.el7
spausedd-2.4.3-6.el7

How reproducible:
always

Steps to Reproduce:
1. Check file permissions
# ls -l /usr/lib/systemd/system/spausedd.service
-rwxr-xr-x. 1 root root 214 Mar 20 09:16 /usr/lib/systemd/system/spausedd.service

Actual results:
Executable bit is set.

Expected results:
Executable bit is NOT set.

Additional info:

Comment 1 Jan Friesse 2019-08-06 11:32:25 UTC
Proposed change in corosync.spec file:

@@ -236,7 +237,7 @@ make DESTDIR="%{buildroot}" PREFIX="%{_prefix}" install
 
 %if %{with systemd}
 mkdir -p %{buildroot}/%{_unitdir}
-install -m 755 -p init/spausedd.service %{buildroot}/%{_unitdir}
+install -m 644 -p init/spausedd.service %{buildroot}/%{_unitdir}
 %else
 mkdir -p %{buildroot}/%{_initrddir}
 install -m 755 -p init/spausedd %{buildroot}/%{_initrddir}

Comment 3 Patrik Hagara 2019-11-05 15:23:24 UTC
before
======

> [root@virt-060 ~]# rpm -q spausedd
> spausedd-2.4.3-6.el7.x86_64
> [root@virt-060 ~]# ls -la /usr/lib/systemd/system/spausedd.service
> -rwxr-xr-x. 1 root root 214 Mar 20  2019 /usr/lib/systemd/system/spausedd.service

after
=====

> [root@virt-127 ~]# rpm -q spausedd
> spausedd-2.4.5-4.el7.x86_64
> [root@virt-127 ~]# ls -la /usr/lib/systemd/system/spausedd.service 
> -rw-r--r--. 1 root root 214 Aug  7 08:44 /usr/lib/systemd/system/spausedd.service


marking verified in 2.4.5-4.el7

Comment 5 errata-xmlrpc 2020-03-31 19:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1079


Note You need to log in before you can comment on or make changes to this bug.