Bug 173796 - Do not set hotplug in proc
Summary: Do not set hotplug in proc
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-21 11:56 UTC by Harald Hoyer
Modified: 2019-03-11 13:35 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-01-06 20:04:36 UTC


Attachments (Terms of Use)
host sosreport (19.16 MB, application/octet-stream)
2019-03-11 09:01 UTC, IBM Bug Proxy
no flags Details

Description Harald Hoyer 2005-11-21 11:56:05 UTC
remove the sysctl in rc.sysinit which sets hotplug

Comment 1 Harald Hoyer 2005-11-21 11:57:20 UTC
and also not in /etc/init.d/network

Comment 2 Bill Nottingham 2005-11-21 17:19:34 UTC
Details?

How do you temporarily turn off uevent handling in udev, then? Kill it? :)

Comment 3 Harald Hoyer 2005-11-21 17:36:43 UTC
since udevd uses netlink, udevsend would be overkill... also please move
udev-075-4 from fc5-head to fc5

Comment 4 Harald Hoyer 2005-11-21 17:38:06 UTC
in udev-075-4 I call sysctl for older kernels, which do not use uevent

yes, kill udevd... it connects through netlink to the kernel

Comment 5 Harald Hoyer 2005-11-21 17:38:44 UTC
why do you want to turn off uevent handling?

Comment 6 Bill Nottingham 2005-11-21 17:47:04 UTC
When /etc/init.d/network, you generally want to ignore any hotplug/uevent events
for network devices, as it's expected that things will be added/removed then.
Of course, this can be fixed in net.agent too.

Comment 7 Bill Nottingham 2006-01-06 20:04:36 UTC
This is fixed in current, IIRC.

Comment 8 IBM Bug Proxy 2019-03-11 09:01:11 UTC
Created attachment 1542806 [details]
host sosreport

Comment 9 IBM Bug Proxy 2019-03-11 13:35:12 UTC
Comment on attachment 1542806 [details]
host sosreport

Obsoleting this attachment which was caused by an unexpected LTC mirroring action. My apologies for the disruption to this bug.


Note You need to log in before you can comment on or make changes to this bug.