Bug 1738 - host dumps core on `host -l -t any mvhi.com ns.uu.net'
Summary: host dumps core on `host -l -t any mvhi.com ns.uu.net'
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-24 15:18 UTC by David Woodhouse
Modified: 2014-03-17 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-31 15:52:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 1999-03-24 15:18:21 UTC
devel2 /homes/dwmw2 $ host -l -t any mvhi.com ns.uu.net
Using domain server:
Name: ns.uu.net
Address: 137.39.1.3
Aliases:

Server failed: Premature end of data
Segmentation fault (core dumped)

If you can't reproduce it, let me know and I'll install the
sources and trace it further.

Comment 1 Bill Nottingham 1999-03-24 16:58:59 UTC
quick fix is the following patch:
--- bind-8.2/src/bin/host/host.c.error	Wed Mar 24 11:43:19 1999
+++ bind-8.2/src/bin/host/host.c	Wed Mar 24 11:56:19 1999
@@ -1310,6 +1314,7 @@

 		amtToRead = len;
 		cp = buf.qb2;
+	        if (amtToRead > NS_PACKETSZ) amtToRead=NS_PACKETSZ;
 		while (amtToRead > 0 &&
 		       (numRead = read(sockFD, cp, amtToRead)) > 0) {
 			cp += numRead;

Comment 2 Preston Brown 1999-03-30 21:55:59 UTC
Bill, did you apply the quick and dirty fix?

Comment 3 Bill Nottingham 1999-03-31 15:52:59 UTC
fixed in bind-8.2-6


Note You need to log in before you can comment on or make changes to this bug.