Bug 173805 - frequent dmesg entries: "eth0: freeing mc frame."
frequent dmesg entries: "eth0: freeing mc frame."
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-11-21 09:27 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-07 09:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of sysreport (570.39 KB, application/octet-stream)
2005-12-01 18:13 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-11-21 09:27:50 EST
Description of problem:
Odd messages showing up in dmesg:
  eth0: freeing mc frame. 

ifconfig shows:
 eth0     Link encap:Ethernet  HWaddr 00:D0:B7:81:CB:A8
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::2d0:b7ff:fe81:cba8/64 Scope:Link
          RX packets:931 errors:0 dropped:0 overruns:0 frame:0
          TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:59502 (58.1 KiB)  TX bytes:295047 (288.1 KiB)

lspci shows:
  02:04.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100]
(rev 05)

Version-Release number of selected component (if applicable):

How reproducible:
Occuring at about 1 per sec

Steps to Reproduce:
1. dmesg
Actual results:
eth0: freeing mc frame.

Expected results:

Additional info:
Comment 1 John Ellson 2005-11-21 09:46:59 EST
Stopping avahi-daemon stops the messages.   
Comment 2 John W. Linville 2005-12-01 10:47:58 EST
Please try using the e100 driver instead of the eepro100.  
Edit /etc/modprobe.conf and change all references to "eepro100" to reference 
"e100" instead. 
Please give that a try and post the results...thanks! 
Comment 3 John Ellson 2005-12-01 13:43:01 EST
There were no references to eepro100 that I could find.
It alread had "alias eth0 e100" in /etc/modprobe.conf

I can't recreate the problem today, with or without avahi-daemon running.

Comment 4 John Ellson 2005-12-01 13:47:26 EST
CORRECTION  I *can* recreate the problem today with the packages.

(I was checking /var/log/messages instead of dmesg.  I should read my own bug
reports!  )

With avahi-daemon running, dmesg is getting "eth0: freeing mc frame" messages.

With avahi-daemon stopped, the dmesg messages stop.

There are no relevant messages in /var/log/messages.
Comment 5 John W. Linville 2005-12-01 17:44:32 EST
Very strange...the text for "freeing mc frame" is only in the eepro100 driver, 
not the e100 driver. 
Please attach the output from running sysreport...thanks! 
Comment 6 John Ellson 2005-12-01 18:13:14 EST
Created attachment 121720 [details]
output of sysreport

sysreport generated with avahi-daemon running
Comment 7 John W. Linville 2005-12-02 09:46:21 EST
Your lsmod output shows that you are loading both the eepro100 and e100  
drivers.  It would appear that eepro100 is loading first and claiming the  
Unfortunately, I don't see anything else in the sysreport that explains to me  
how/why eepro100 is getting loaded at all.  The e100 driver should work with  
your hardware.  
Can you find-out how/why eepro100 is getting loaded on your box?  If nothing  
else, please attach the output of this command:  
   find /etc -type f -exec grep -l eepro100 {} \;  
You might also try this (as root): 
   mv /lib/modules/`uname -r`/kernel/drivers/net/eepro100.ko /root 
Hopefully that will prevent eepro100 from loading... :-) 
Comment 8 John W. Linville 2005-12-02 09:49:23 EST
You might try this is an a nicer alternative to the 'mv' command above: 
   echo eepro100 >> /etc/hotplug/blacklist 
Please try that and reboot, and post the results here...thanks! 
Comment 9 John Ellson 2005-12-02 10:24:23 EST
    find /etc -type f -exec grep -l eepro100 {} \; 
returned nothing.

    echo eepro100 >> /etc/hotplug/blacklist 
and rebooting didn't prevent eepro100 from being loaded   !!!
lsmod shows both e100 and eepro100 as loaded.

Is it significant that the two interfaces are on a single PCI card?

I have:
    alias eth0 e100
    alias eth1 e100
in /etc/modprobe.conf .   Is it possible that this file is being ignored in
favor of /etc/modprobe.d/modprobe.conf.dist ?

I tried:
    mv /lib/modules/`uname -r`/kernel/drivers/net/eepro100.ko /root
and that worked: eepro100 module not loaded, starting avahi-daemon doesn't
produce error messages in dmesg.

But this is just hiding the problem under the rug.
I have other systems that are also loading both drivers for no apparent reason.

Comment 10 John Ellson 2005-12-02 10:38:56 EST
I've put back the module so that I can test.

    alias eth0 e100
    alias eth1 e100
to /etc/modprobe.d/modprobe.conf.dist and the rebooting did not fix the problem.

Comment 11 John Ellson 2005-12-02 10:48:16 EST
I tried
   rmmod eepro100
and I've lost remote access to the system, so I won't be able to test further
until I get home this afternoon.

I was wondering if the eepro100 module was getting installed via mkinitrd and
just getting carried through from one version of the kernel to the next.  I was
going to:
    rmmod eepro100
    mkinitrd .....
then reboot to see if that avoided reloading it.    I'll try the experiment
later unless you have other ideas.

Comment 12 Dave Jones 2005-12-02 18:58:17 EST
Hmm, we could probably just disable the EEPRO100 driver for fc5. The only thing
it does that e100 doesn't afaik is work on some wierdo ARM platform which we
don't build for in Fedora anyway.
Comment 13 John Ellson 2005-12-02 20:15:21 EST
Its being loaded by mkinitrd but not getting carried forward that way.

With the eepro100.ko file in out of the way I rebooted the system
so that only e100 was loaded.  Then I did a mkinitrd  and then put
eepro100.ko back in its normal place.   The I rebooted and 
lsmod showed no eepro100 loaded.

I then upgraded to kernel-2.6.14-1.1735_FC5 and rebooted
and the eepro100 module was loaded again.

There are lots of references to eepro100 in /lib/modules/2.6.14-1.1735_FC5/module*
so my guess is that /sbin/depmod is not creating the right module dependencies
during kernel installs.
Comment 14 John W. Linville 2005-12-05 10:51:48 EST
I'm kinda leaning towards Dave's suggestion from comment 12...  Dave, do you 
want a patch? 
Comment 15 Dave Jones 2005-12-06 17:02:56 EST
I've just disabled eepro100 in the config. After this, everything should just
pick up the e100 driver and 'just work'.  hwdata already has the eepro100 ->
e100 migration, so upgrades should be fine.  Adding Bill to cc as a sanity check :-)
Comment 16 Bill Nottingham 2005-12-07 01:50:31 EST
Should work fine to remove it.

Note You need to log in before you can comment on or make changes to this bug.