Bug 173818 - binary contains a hardcoded rpath on x86_64 and fails to find the "correct" libGl.so.1 due to that
binary contains a hardcoded rpath on x86_64 and fails to find the "correct" l...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ppracer (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2005-11-21 10:58 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 10:15:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2005-11-21 10:58:56 EST
Description of problem:
The ppracer binary contains the hardcoded rpath /usr/lib64 in it. This is bad
because it overrides the normal ldconfig way to find the correct librarys. 

This results in a problem that shows up together with the nvidia or ati drivers
from livna.org. The libGL.so.1 for the ati drivers for example is placed in
/usr/lib64/ati-fglrx/ and activated by having a line with
"/usr/lib64/ati-fglrx/" on top of /etc/ld.so.conf. This normaly works fine. But
ppracer contains this hardcoded rpath and therefor uses the libGL.so.1 from
/usr/lib64. Therefore ppracer won't work on x86_64-systems with the ati or
nvidia drivers from livna.

Version-Release number of selected component (if applicable):
0.3.1-4

How reproducible:
Always

Steps to Reproduce:
$/usr/lib/rpm/check-rpaths-worker /usr/bin/ppracer
[...]
ERROR   0001: file '/usr/bin/ppracer' contains a standard rpath '/usr/lib64' in
[/usr/lib64]
  
Additional info:
The rpatch is a result of a bug in fontconfig:
$ freetype-config --libs
-L/usr/lib64 -Wl,--rpath -Wl,/usr/lib64 -lfreetype -lz

This is fixed in devel 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160247
but it seems we won't get this fixed in FC3 or FC4:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139199

Suggested workaround:
- in configure sed-away the rpath with something like
/usr/bin/freetype-config --libs | sed 's|-Wl,--rpath -Wl,/usr/lib64 ||'

- sed away the rpath in the Makefiles after running configure with something like:
sed -i 's|-Wl,--rpath -Wl,/usr/lib64 ||' $(find . -name 'Makefile')
Comment 1 Thorsten Leemhuis 2005-11-21 11:04:26 EST
FYI: Filed Bug 173819 for a similar problem with neverball
Comment 2 Nils Philippsen 2006-02-15 10:39:00 EST
I've just checked in your fix to CVS, but the buildsystem is broken ATM. Will
try later.
Comment 3 Nils Philippsen 2006-02-15 12:19:59 EST
... building right now.
Comment 4 Nils Philippsen 2006-02-17 10:15:53 EST
Should be fixed in ppracer-0.3.1-4.fc4.1.

Note You need to log in before you can comment on or make changes to this bug.