Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1738211 - Help contains old info that is not valid anymore
Summary: Help contains old info that is not valid anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhv-log-collector-analyzer
Version: 4.3.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ovirt-4.3.6
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: Guilherme Santos
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-06 14:14 UTC by Ivana Saranova
Modified: 2019-10-10 15:37 UTC (History)
3 users (show)

Fixed In Version: rhv-log-collector-analyzer-0.2.9-0.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 15:37:40 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3012 0 None None None 2019-10-10 15:37:46 UTC

Description Ivana Saranova 2019-08-06 14:14:15 UTC
Description of problem:
When seeing the help message from the analyzer, it contains info about usage with tar archive that is no longer valid. Also the --live parameter should be marked as deprecated as it used by default.

Version-Release number of selected component (if applicable):
rhv-log-collector-analyzer-0.2.8-0.el7ev.noarch
ovirt-engine-4.3.6-0.1.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. `rhv-log-collector-analyzer --help`
2.
3.

Actual results:
sage: /usr/bin/rhv-log-collector-analyzer [options] <tar-file>
    --live
        Use live system to determine possible issues, output HTML
    --json
        Use live system to determine possible issues, output JSON
Script unpacks sosreport, import it into db and generates html report into current directory.
To change temporary directory use: export TMPDIR=/my-tmp-dir


Expected results:
No part about the tar archive usage and a note for the --live parameter about being deprecated.

Additional info:

Comment 2 Guilherme Santos 2019-08-28 13:18:18 UTC
Verified on rhv-log-collector-analyzer-0.2.10-0.el7ev.noarch

Comment 4 errata-xmlrpc 2019-10-10 15:37:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3012


Note You need to log in before you can comment on or make changes to this bug.