Bug 173828 - Alt-1 thru Alt-0 no longer work properly
Alt-1 thru Alt-0 no longer work properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-21 13:36 EST by Wayne Walker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 22:16:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This still shows gnome-term working and xterm 207 still sending bad characters. (101.51 KB, image/png)
2005-11-23 18:11 EST, Chris Tooley
no flags Details

  None (edit)
Description Wayne Walker 2005-11-21 13:36:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
When I use Alt-1 thru Alt-0 in an xterm, I get:

±²´³´µ¶·¸¹°

Instead of getting Esc-1 thru Esc-0.  The console produces the correct keystrokes still, and so does gnome-terminal.

Version-Release number of selected component (if applicable):
xterm-205-1.FC4

How reproducible:
Always

Steps to Reproduce:
1. Open an xterm, run 'wc' press Alt-1, Alt-2, ...Alt-0
2. Open a gnome-terminal, run 'wc' press Alt-1, Alt-2, ...Alt-0
3.
  

Actual Results:  xterm:
±²´³´µ¶·¸¹°

gnome-terminal:
^[1^[2^[3^[4^[5^[6^[7^[8^[9^[0


Expected Results:  xterm should have output what gnome-terminal did

Additional info:
Comment 1 Jason Vas Dias 2005-11-23 14:16:56 EST
This problem should be fixed with xterm-207-1.FC4, now in FC-4 Updates/Testing .
Comment 2 Chris Tooley 2005-11-23 18:11:28 EST
Created attachment 121420 [details]
This still shows gnome-term working and xterm 207 still sending bad characters.
Comment 3 Thomas E. Dickey 2005-11-23 19:55:00 EST
xterm #207 has menu entries to alter this behavior at runtime.
Look at the control/left mouse menu (which also corresponds to
resource settings).  It sounds as if you want to look at
"Alt Sends Escape" (resource altSendsEscape).  That's in the
manpage (for xterm, of course).
Comment 4 Jason Vas Dias 2005-11-23 22:17:19 EST
Sorry - I had tested this bug with xterm-207 on FC-5test1 (modular X11), 
where I found that xterm still requires the 
  '*VT100*eightBitInput: 0'
resource in order to enable the 'altSendsEscape' resource by default, and
once it is enabled by default, the <ALT>+KEY keystroke is translated 
correctly.

xterm-207 does NOT require this resource on FC-5 to properly translate the
backspace key, as it does on FC-4 (a different bug).

On FC-4, where '*VT100*eightBitInput: 0' is also the default for xterm-207,
the 'altSendsEscape' resource is NOT enabled by default , even if the 
app-defaults/XTerm* files and locale are identical to those on FC-5 .

Hence this does not appear to be an xterm issue, but rather an issue with
the libraries xterm uses (the same code behaves differently with the same
app-defaults and locale, only different X11 libraries).

So on FC-4, the 'altSendsEscape' resource is NOT enabled by default , 
while on FC-5, it is. I'll need to investigate further to find out 
exactly why - perhaps because of different X11 versions.

You can make the altSendsEscape:1 your default setting by putting the line:
'*VT100*altSendsEscape:1' in your ~/.Xresources file . 

I'm not sure we should make this the default, since it would annoy users who
do not want altSendsEscape, and this is a user configurable setting.
Comment 5 Bill Nottingham 2006-09-21 22:16:10 EDT
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.

Note You need to log in before you can comment on or make changes to this bug.