Bug 1738380 - kernel freeze after upgrade
Summary: kernel freeze after upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: aarch64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-07 03:55 UTC by Stuart D Gathman
Modified: 2019-08-12 15:50 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-12 15:50:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Stuart D Gathman 2019-08-07 03:55:57 UTC
1. Please describe the problem:
kernel freezes with blank screen shortly after loading

2. What is the Version-Release number of the kernel:
kernel-5.2.5-200.fc30.aarch64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
Yes, appeared with 5.2.5-200.fc30.aarch64
The last working kernel is 5.1.20-300.fc30.aarch64

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Select new kernel from grub

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
I see 5.2.6 just landed in updates-testing.  I'll give that a try.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
no

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

system freezes before any logs are displayed on screen or saved in a writable filesystem.  caplock key does not toggle indicator - showing kernel is totally dead.

Comment 1 Stuart D Gathman 2019-08-07 04:30:04 UTC
5.2.6 also freezes.  This is on a Pinebook 1080P.  When I get a chance, I'll try on an rPi3.

Comment 2 Stuart D Gathman 2019-08-07 14:19:31 UTC
5.2.6 works fine on rPi3, so it is likely a problem specific to pinebook.

Comment 3 Stuart D Gathman 2019-08-07 15:33:15 UTC
The rawhide kernel 5.3.0-0.rc3.git0.1.fc31.aarch64 runs!  So only the 5.2.x kernels are broken on pinebook.

Comment 4 Stuart D Gathman 2019-08-12 14:28:34 UTC
kernel-5.2.7-200.fc30.aarch64 runs!  So the problem has been fixed.  I didn't see any documentation as to what the problem was specifically.  I'll check out 5.2.8 before closing.

Comment 5 Stuart D Gathman 2019-08-12 15:50:13 UTC
5.2.8 doesn't freeze either.  So this has been fixed for 2 consecutive versions.  I'll close it.


Note You need to log in before you can comment on or make changes to this bug.