Bug 1738412 - The manifests for kubefed controller and webhook are not correct in the downstream kubefed-operator image
Summary: The manifests for kubefed controller and webhook are not correct in the downs...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.0
Assignee: Aniket Bhat
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-07 06:23 UTC by Qin Ping
Modified: 2019-10-16 06:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:35:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:35:27 UTC

Description Qin Ping 2019-08-07 06:23:54 UTC
Description of problem:
The manifests for kubefed controller and webhook are not correct in the downstream kubefed-operator image

Version-Release number of selected component (if applicable):
kubefed-operator image version: quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.2.0-201908061459-ose-kubefed-operator

How reproducible:
100%

Steps to Reproduce:
1. # podman images|grep ose-kubefed-operator
quay.io/openshift-release-dev/ocp-v4.0-art-dev   v4.2.0-201908061459-ose-kubefed-operator                                  ca7463696de5   11 hours ago   296 MB
2. # podman run --rm --entrypoint /bin/sh  ca7463696de5 -c 'cat /deploy/resources/controller/deployment.yaml|grep command -A 1'
        command:
        - /hyperfed/controller-manager

3. # podman run --rm --entrypoint /bin/sh  ca7463696de5 -c 'cat /deploy/resources/webhook/webhook_deployment.yaml|grep command -A 1'
        command:
          - "/hyperfed/webhook"

Actual results:
The binary files are exist in the root dir not the hyperfed dir.
When starting kubefed webhook, getting the following error:
Warning  Failed     14s (x6 over 76s)  kubelet, ip-10-0-156-22.ap-northeast-1.compute.internal  Error: container create failed: container_linux.go:336: starting container process caused "exec: \"/hyperfed/webhook\": stat /hyperfed/webhook: no such file or directory"
  

Expected results:


Additional info:

Comment 4 Qin Ping 2019-08-12 06:56:23 UTC
Verified with images:
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.2.0-201908081419-ose-kubefed
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.2.0-201908070857-ose-kubefed-operator

Comment 5 errata-xmlrpc 2019-10-16 06:35:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.