Bug 1738456 - [DOCS] master would become schedulable in all UPI install
Summary: [DOCS] master would become schedulable in all UPI install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.2.z
Assignee: Kathryn Alexander
QA Contact: Johnny Liu
Vikram Goyal
URL:
Whiteboard:
: 1755073 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-07 08:48 UTC by Johnny Liu
Modified: 2019-10-17 15:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-17 15:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Johnny Liu 2019-08-07 08:48:33 UTC
Document URL: 
https://docs.openshift.com/container-platform/4.1/installing/installing_bare_metal/installing-bare-metal.html#installation-bare-metal-config-yaml_installing-bare-metal
https://docs.openshift.com/container-platform/4.1/installing/installing_aws_user_infra/installing-aws-user-infra.html#installation-generate-aws-user-infra_installing-aws-user-infra
https://docs.openshift.com/container-platform/4.1/installing/installing_vsphere/installing-vsphere.html#installation-vsphere-config-yaml_installing-vsphere

Section Number and Name: 
Sample install-config.yaml file

Describe the issue: 
In our existing doc, we are telling user to set worker replica to 0, while since https://github.com/openshift/installer/blob/master/pkg/asset/manifests/scheduler.go#L64-L73 is merged, that would make all masters become schedulable. That means user's pods maybe scheduled to any master node. I do not think this is what user expected.
Per https://github.com/openshift/installer/pull/2004, there are long discussion about this new change, what we should tell user to do in our 4.2 official doc? What is our finial recommendation. This is a big change, at least a massive change is required in doc.

Suggestions for improvement: 

Additional information:

Comment 4 Kathryn Alexander 2019-10-02 19:47:43 UTC
PR's here: https://github.com/openshift/openshift-docs/pull/17016

I'm asking Trevor to take a look before I put it on QE.

Comment 5 Kathryn Alexander 2019-10-04 14:30:43 UTC
@Jianlin, will you PTAL? https://github.com/openshift/openshift-docs/pull/17016

Comment 6 Johnny Liu 2019-10-11 06:47:43 UTC
upi on aws looks good to me.
Where is upi on vsphere, and upi on baremetal PR?

Comment 9 W. Trevor King 2019-10-14 22:40:24 UTC
*** Bug 1755073 has been marked as a duplicate of this bug. ***

Comment 12 Kathryn Alexander 2019-10-15 13:20:07 UTC
I updated the PR to add the steps to generate the manifest files and modify the cluster-scheduler-02-config.yml file to vsphere and bare metal.

Comment 13 Kathryn Alexander 2019-10-15 13:20:29 UTC
@Jianlin, will you please take another look?

Comment 14 Johnny Liu 2019-10-16 02:09:33 UTC
The PR for aws/gcp looks good to me.

Waiting for new PR for vsphere and baremetal.

Comment 15 Kathryn Alexander 2019-10-16 02:21:26 UTC
Because of the change I had to make to cover vSphere and bare metal, I added them to this PR. (eg https://bz1738456--ocpdocs.netlify.com/openshift-enterprise/latest/installing/installing_vsphere/installing-vsphere.html#installation-user-infra-generate-k8s-manifest-ignition_installing-vsphere)

Comment 16 Johnny Liu 2019-10-16 02:34:33 UTC
Ah, I lost your new change. LGTM.

Comment 17 Kathryn Alexander 2019-10-16 12:23:38 UTC
Thank you! My apologies for the confusion. I've merged the change and am waiting for it to go live.


Note You need to log in before you can comment on or make changes to this bug.