Bug 1738529 - Dry-run fails on TASK [Sync cached facts]
Summary: Dry-run fails on TASK [Sync cached facts]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: All
OS: All
urgent
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-07 11:39 UTC by Marius Cornea
Modified: 2019-12-16 21:16 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190819100442.4b9c363.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:24:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1839321 0 None None None 2019-08-07 12:32:02 UTC
OpenStack gerrit 675621 0 'None' MERGED Force "Pre-cache" tasks to run in dry run 2021-01-15 19:44:37 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:41 UTC

Description Marius Cornea 2019-08-07 11:39:09 UTC
Description of problem:

Dry-run fails on TASK [Sync cached facts]:

TASK [Sync cached facts] *******************************************************
fatal: [controller-1 -> 192.168.24.7]: FAILED! => {"changed": false, "cmd": "/bin/rsync --delay-updates -F --compress --dry-run --archive --out-format=<<CHANGED>>%i %n%L /opt/puppetlabs/ /var/lib/container-puppet/puppetlabs/", "msg": "rsync: change_dir \"/opt/puppetlabs\" failed: No such file or directory (2)\nrsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1189) [sender=3.1.3]\n", "rc": 23}
fatal: [controller-0 -> 192.168.24.19]: FAILED! => {"changed": false, "cmd": "/bin/rsync --delay-updates -F --compress --dry-run --archive --out-format=<<CHANGED>>%i %n%L /opt/puppetlabs/ /var/lib/container-puppet/puppetlabs/", "msg": "rsync: change_dir \"/opt/puppetlabs\" failed: No such file or directory (2)\nrsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1189) [sender=3.1.3]\n", "rc": 23}
fatal: [controller-2 -> 192.168.24.21]: FAILED! => {"changed": false, "cmd": "/bin/rsync --delay-updates -F --compress --dry-run --archive --out-format=<<CHANGED>>%i %n%L /opt/puppetlabs/ /var/lib/container-puppet/puppetlabs/", "msg": "rsync: change_dir \"/opt/puppetlabs\" failed: No such file or directory (2)\nrsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1189) [sender=3.1.3]\n", "rc": 23}
fatal: [compute-0 -> 192.168.24.17]: FAILED! => {"changed": false, "cmd": "/bin/rsync --delay-updates -F --compress --dry-run --archive --out-format=<<CHANGED>>%i %n%L /opt/puppetlabs/ /var/lib/container-puppet/puppetlabs/", "msg": "rsync: change_dir \"/opt/puppetlabs\" failed: No such file or directory (2)\nrsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1189) [sender=3.1.3]\n", "rc": 23}
fatal: [compute-1 -> 192.168.24.12]: FAILED! => {"changed": false, "cmd": "/bin/rsync --delay-updates -F --compress --dry-run --archive --out-format=<<CHANGED>>%i %n%L /opt/puppetlabs/ /var/lib/container-puppet/puppetlabs/", "msg": "rsync: change_dir \"/opt/puppetlabs\" failed: No such file or directory (2)\nrsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1189) [sender=3.1.3]\n", "rc": 23}

Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190801.n.0

How reproducible:
100%

Steps to Reproduce:
1. Execute dry-run with:
ansible-playbook --check --become -i /home/stack/inventory.yaml /home/stack/config-download/deploy_steps_playbook.yaml


Actual results:
Failure during 'Sync cached facts' task

Expected results:
No failure

Additional info:

Comment 8 Victor Voronkov 2019-08-20 17:39:00 UTC
Automation job passed on build containing the patch:
[stack@undercloud-0 ~]$ rpm -qa openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-10.6.1-0.20190819180520.6a38682.el8ost.noarch

https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/df/view/rfe/job/DFG-df-rfe-15-virsh-3cont_2comp_3ceph-dry-run-verification/23/

Comment 12 errata-xmlrpc 2019-09-21 11:24:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.