Bug 1738611 - RHUI Currently Broken in AWS [NEEDINFO]
Summary: RHUI Currently Broken in AWS
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rh-amazon-rhui-client
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Todd Sanders
QA Contact: Vitaly Kuznetsov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-07 15:11 UTC by Thomas Jones
Modified: 2020-01-03 20:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-16 03:21:38 UTC
Target Upstream Version:
xiliang: needinfo?


Attachments (Terms of Use)

Description Thomas Jones 2019-08-07 15:11:05 UTC
Description of problem:

RHUI - at least in the AWS us-east-1 region - appears to be broken


Version-Release number of selected component (if applicable):


How reproducible:




Steps to Reproduce:
1. Launch new instance of RHEL 7.7 AMI published by Red Hat
2. Attempt to install packages or patches (or even just do a `repolist`)


Actual results:

Error message about service being unavailable:

[ec2-user@ip-10-0-44-26 ~]$ yum repolist
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/product/rhui-client-config-server-7.crt
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/rhui-client-config-server-7.key
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/product/content-rhel7.crt
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/content-rhel7.key
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/product/content-rhel7.crt
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/content-rhel7.key
Could not contact CDS load balancer rhui2-cds01.us-east-1.aws.ce.redhat.com, trying others.


Could not contact any CDS load balancers: rhui2-cds01.us-east-1.aws.ce.redhat.com, rhui2-cds02.us-east-1.aws.ce.redhat.com.

Expected results:

Able to list/install available packages/patches or enumerate available repository-channels

Additional info:

Above error is as of 30 seconds ago (and in the us-east-1 region)

Comment 2 Thomas Jones 2019-08-08 11:17:33 UTC
Spun up a new instance this morning and am able to contact the RHUI repository (though, the instance I launched, yesterday, is still failing). Verified that both yesterday's and today's instances were spawned from the same AMI (ami-0916c408cb02e310b). Looks like the specific instance I launched, yesterday, was simply bent - as it is still saying that it can't contact either rhui2-cds01.us-east-1.aws.ce.redhat.com or rhui2-cds02.us-east-1.aws.ce.redhat.com.

Comment 3 Frank Liang 2019-09-09 09:35:58 UTC
Seems non-root user is not able to access any cds and RHUI works well after switched to root or use sudo. I think it is not a bug, but the message is indeed misleading, maybe we can do some enhancement.

$ yum repolist
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/product/rhui-client-config-server-7.crt
Repo rhui-REGION-client-config-server-7 forced skip_if_unavailable=True due to: /etc/pki/rhui/rhui-client-config-server-7.key
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/product/content-rhel7.crt
Repo rhui-REGION-rhel-server-releases forced skip_if_unavailable=True due to: /etc/pki/rhui/content-rhel7.key
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/cdn.redhat.com-chain.crt
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/product/content-rhel7.crt
Repo rhui-REGION-rhel-server-rh-common forced skip_if_unavailable=True due to: /etc/pki/rhui/content-rhel7.key
Could not contact CDS load balancer rhui2-cds01.us-east-1.aws.ce.redhat.com, trying others.


Could not contact any CDS load balancers: rhui2-cds01.us-east-1.aws.ce.redhat.com, rhui2-cds02.us-east-1.aws.ce.redhat.com.

$ sudo yum repolist
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
rhui-REGION-client-config-server-7                                                                                 | 2.9 kB  00:00:00     
rhui-REGION-rhel-server-releases                                                                                   | 3.5 kB  00:00:00     
rhui-REGION-rhel-server-rh-common                                                                                  | 3.8 kB  00:00:00     
(1/7): rhui-REGION-client-config-server-7/x86_64/primary_db                                                        | 3.3 kB  00:00:00     
(2/7): rhui-REGION-rhel-server-releases/7Server/x86_64/group                                                       | 773 kB  00:00:00     
(3/7): rhui-REGION-rhel-server-rh-common/7Server/x86_64/group                                                      |  124 B  00:00:00     
(4/7): rhui-REGION-rhel-server-rh-common/7Server/x86_64/primary_db                                                 | 118 kB  00:00:00     
(5/7): rhui-REGION-rhel-server-releases/7Server/x86_64/updateinfo                                                  | 3.4 MB  00:00:00     
(6/7): rhui-REGION-rhel-server-rh-common/7Server/x86_64/updateinfo                                                 |  34 kB  00:00:00     
(7/7): rhui-REGION-rhel-server-releases/7Server/x86_64/primary_db                                                  |  61 MB  00:00:01     
repo id                                                   repo name                                                                 status
rhui-REGION-client-config-server-7/x86_64                 Red Hat Update Infrastructure 2.0 Client Configuration Server 7                2
rhui-REGION-rhel-server-releases/7Server/x86_64           Red Hat Enterprise Linux Server 7 (RPMs)                                  26,283
rhui-REGION-rhel-server-rh-common/7Server/x86_64          Red Hat Enterprise Linux Server 7 RH Common (RPMs)                           239
repolist: 26,524

Comment 4 Frank Liang 2019-11-27 07:05:30 UTC
Hi Thomas,

Does the problem still exist? Thanks

Comment 5 Frank Liang 2019-12-16 03:21:38 UTC
I am closing this issue for now and please feel free to re-open it if it is reproducible.


Note You need to log in before you can comment on or make changes to this bug.