Bug 1738650 - Kernel 5.2.5 graphics unstable
Summary: Kernel 5.2.5 graphics unstable
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2019-08-07 17:59 UTC by Jerry
Modified: 2019-09-05 02:40 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-09-05 02:40:07 UTC
Type: Bug

Attachments (Terms of Use)
Example of Issue, screenshot (379.08 KB, image/png)
2019-08-09 17:36 UTC, Jerry
no flags Details
Example dmesg (84.71 KB, text/plain)
2019-08-09 17:40 UTC, Jerry
no flags Details

Description Jerry 2019-08-07 17:59:31 UTC
1. Please describe the problem:

Updated Fedora 30 yesterday, 8-6-2019. New kernel 5.2.5-200.fc30.x86_64 boots OK. Graphics within windows of apps such as Thunderbird get scrambled. It appears some windows work OK for example keepass appears to work cleanly which uses different libraries.

I don't know how to check what other updates came in yesterday, there were more than just the kernel. If I can check the update history??? I can update this report with what else was changed. This is not the same as the raven_dmcu.bin firmware issue reported in https://bugs.freedesktop.org/show_bug.cgi?id=109206

Booting on previous version of kernel all works well. Previous Kernel is 

args="ro resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet idle=nomwait"
title="Fedora (5.1.20-300.fc30.x86_64) 30 (Thirty)"

2. What is the Version-Release number of the kernel:

args="ro resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet idle=nomwait"
title="Fedora (5.2.5-200.fc30.x86_64) 30 (Thirty)"

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Yes as noted above

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Yes, every time.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Have not tried this

6. Are you running any modules that not shipped with directly Fedora's kernel?:

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Will attache if I can get after a boot back to problem kernel

Comment 1 Jerry 2019-08-09 17:36:31 UTC
Created attachment 1602255 [details]
Example of Issue, screenshot

Changing title to narrow scope. New Ryzen 2500U issue

Comment 2 Jerry 2019-08-09 17:38:09 UTC
Problem persists in 5.2.6 downloaded today.

Comment 3 Jerry 2019-08-09 17:40:26 UTC
Created attachment 1602256 [details]
Example dmesg

Nothing obvious to me. Latest BIOS here has been working fine before jump to kernel 5.2.

Please advize on any data needed.

Comment 4 Alain Reguera Delgado 2019-08-11 17:53:51 UTC
Problem persists in kernel-5.2.7, ThinkPad E585 (AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx).

Comment 5 Alain Reguera Delgado 2019-08-11 18:02:08 UTC
Problem doesn't seem to affect kernel-5.0.9-301.fc30.x86_64, but higher versions only.

Comment 6 Jerry 2019-08-29 02:10:58 UTC
Problem still persists with kernel-5.2.9-200.fc30.x86_64. Last usable kernel is kernel-5.1.20-300.fc30.x86_64.

Anyone have any suggestions?

Comment 7 Jesper Sørensen 2019-08-31 20:45:47 UTC
I believe I've had the same issue on my Thinkpad A485.

Kernel 5.1.12 worked fine,
Using 5.2.8 or 5.2.9 resulted in visual corruption and eventually a hard freeze.

Before creating a bug report I wanted to ensure that I had the latest updates, including the laptop's BIOS.
So I updated all packages - which didn't solve the issue, then I updated the BIOS from 1.11 to 1.24 and the problem seems to be gone.

I am not sure whether the fix was the BIOS update itself, or the reset of the BIOS settings.
I did toy around with the BIOS to prevent the random freeze issue that's plaguing the A485s.

I'm going to have a look around the BIOS and see if some setting can recreate the issue.

Comment 8 Jerry 2019-09-05 02:40:07 UTC
With the kernel-5.2.11-200.fc30.x86_64 update that came in today, this bug appears to be fixed.

Al stable.


Note You need to log in before you can comment on or make changes to this bug.