Bug 173876 - ACPI recursion check cleanup failure
ACPI recursion check cleanup failure
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-11-21 20:49 EST by Richard Henderson
Modified: 2015-01-04 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-14 15:46:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Henderson 2005-11-21 20:49:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Either the ACPI bios is actually flawed and the check isn't cleaning things up afterward (since all subsequent executions fail), or the check itself is flawed.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
cat /proc/acpi/battery/BAT[01]/info

Actual Results:  present:                 yes
ERROR: Unable to read battery information

and dmesg will log

    ACPI-0213: *** Error: Method reached maximum reentrancy limit (255)
    ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.LPC_.EC__.BAT1._BIF] (Node c14cf500), AE_AML_METHOD_LIMIT

Expected Results:  No error.

Additional info:

I recently replaced the battery on my Thinkpad T41.  At that time, I added a second battery in place of the cdrom that I rarely use.  At some point after
booting the machine, the battery applet will claim no battery installed.  At
the same time, the behaviour indicated above will be present.

This doesn't happen right away, but once it happens it happens every time.
To me this suggests some sort of resource or counter leak.

I'm not sure what other sort of information I can provide.
Comment 1 Richard Henderson 2005-11-22 13:36:38 EST
The problem doesn't appear in kernel-2.6.13-1.1532_FC4.
Comment 2 Dave Jones 2005-12-10 01:17:19 EST
does booting with acpi_serialize "fix" it ?
Comment 3 Richard Henderson 2005-12-12 15:58:01 EST
Apparently.  2.6.14-1.1644_FC4 (which also displayed the problem) has been
up for about two hours now without the problem appearing.
Comment 4 Dave Jones 2005-12-12 18:48:27 EST
will be interested to hear if the 1650_FC4 kernel from
http://people.redhat.com/davej/kernels/Fedora/FC4 fixes it too (without the
serialize bootarg)
Comment 5 Richard Henderson 2005-12-14 15:30:41 EST
The 1651 kernel does in fact fix the problem.
Comment 6 Dave Jones 2005-12-14 15:46:12 EST
cool, progress!

Note You need to log in before you can comment on or make changes to this bug.