Bug 1738859 - Cannot connect to wifi on kernel 5.2.6 Realtek RTL8822BE
Summary: Cannot connect to wifi on kernel 5.2.6 Realtek RTL8822BE
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-08 09:58 UTC by tiny6996
Modified: 2020-03-06 05:42 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-06 05:42:11 UTC
Type: Bug


Attachments (Terms of Use)
output of lsmod for kernel 5.1.20 (4.76 KB, text/plain)
2019-08-08 10:41 UTC, tiny6996
no flags Details
output of lsmod for kernel 5.2.5 (4.78 KB, text/plain)
2019-08-08 10:42 UTC, tiny6996
no flags Details

Description tiny6996 2019-08-08 09:58:17 UTC
Description of problem: I cannot see a list of networks or connect to wifi on kernel 5.2.5


Version-Release number of selected component (if applicable): Linux Kernel 5.2.5


How reproducible: everytime I login on that kernel


Steps to Reproduce:
1. turn on computer
2. login to desktop
3. click network manager icon in the system tray

Actual results: 
no networks listed 

Expected results:
can select wifi connection from dropdown and automatically connects to home network

Additional info:
Device: Lenovo e485
Wifi chip: realtek RTL8822BE
works in kernel 5.1.x on fedora 30

Comment 1 tiny6996 2019-08-08 10:41:57 UTC
Created attachment 1601770 [details]
output of lsmod for kernel 5.1.20

Comment 2 tiny6996 2019-08-08 10:42:57 UTC
Created attachment 1601771 [details]
output of lsmod for kernel 5.2.5

Comment 3 tiny6996 2019-08-08 10:44:54 UTC
based on the attached output from lsmod it looks like drivers changed from rtw88 and rtwpci from r8822be.

Comment 4 Andrew Cook 2019-08-11 04:04:54 UTC
https://patchwork.kernel.org/patch/11065631/
This patch fixes it for me

The previous r8822be driver used msi interupts, the patch above implements them for rtwpci

Card is assigned irq 16 on my laptop (asus gl702zc) but that irq never fires, i its either misconfigured by the bios or outright broken in the card. either way msi works

Comment 5 tiny6996 2019-08-16 04:51:50 UTC
Thank you for the advice Andrew I will swapped the card with an intel card I had laying around I will test the reltek card on my desktop tomorrow

Comment 6 Justin M. Forbes 2020-03-03 16:27:23 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 30 kernel bugs.

Fedora 30 has now been rebased to 5.5.7-100.fc30.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 31, and are still experiencing this issue, please change the version to Fedora 31.

If you experience different issues, please open a new bug report for those.

Comment 7 tiny6996 2020-03-06 05:42:11 UTC
The bug no longer occurs on fedora 31


Note You need to log in before you can comment on or make changes to this bug.