Bug 1738894 - [RFE] implement additional compute resource attributes for RHV provisioning
Summary: [RFE] implement additional compute resource attributes for RHV provisioning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 6.7.0
Assignee: Oleh Fedorenko
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On: 1336437
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-08 11:23 UTC by Roman Plevka
Modified: 2020-04-14 15:54 UTC (History)
11 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_foreman-0.19.6.4-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 15:54:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 27554 0 Normal Closed Implement additional compute resource attributes for RHV provisioning 2020-10-19 13:17:25 UTC
Foreman Issue Tracker 29026 0 Normal Closed ovirt - fix help in Boolean values 2020-10-19 13:17:37 UTC
Red Hat Product Errata RHBA-2020:1455 0 None None None 2020-04-14 15:54:21 UTC

Description Roman Plevka 2019-08-08 11:23:44 UTC
Description of problem:

RFE BZ#1559006 introduced some extra RHV options for Storage.
e.g.: "Preallocate disk", "Wipe disk after delete", "disk interface"

It is possible that these params can be simply passed as key=value inside cr_attributes, however it would be good to document them (show them in help)

Version-Release number of selected component (if applicable):
6.6.0 snap 14
Steps to Reproduce:
1. navigate to Create new host page, use RHEV compute resource and at virtual machine tab, choose custom template. then observe all the options for "Storage"
2. Try to set these as parameters using hammer

Comment 3 Oleh Fedorenko 2019-08-08 15:01:07 UTC
Created redmine issue https://projects.theforeman.org/issues/27554 from this bug

Comment 4 Bryan Kearney 2019-08-22 14:07:23 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/27554 has been resolved.

Comment 5 Lukáš Hellebrandt 2020-01-28 10:07:47 UTC
In bug 1336437, I discovered that oVirt interface parameter is missing from help. With a quick look, I can see the other parameters mentioned in OP - preallocate and wipe_after_delete, are present.

Comment 6 orabin 2020-02-04 11:46:30 UTC
If oVirt interface is the only parameter missing and is already tracked in bug 1336437, why is this bug failed qa?

Comment 7 Lukáš Hellebrandt 2020-02-04 12:01:25 UTC
Because I think the other bug is subset of this bug. I marked this one failed (rather than merely marking the other one as blocking for this one) because the field is explicitly mentioned in the OP. If you disagree, I think it won't hurt to flip this one back to ON_QA but it will still be blocked.

Comment 8 orabin 2020-02-04 12:29:15 UTC
This was marked as blocking the other bug and now it depends on it so it's clear they can only be tested together.
The other bug is modified and waiting to get merged so to keep track I'm changing this to on_qa and setting the "depends on" field.
Once the other bug moves to on_qa they can be tested.

Comment 9 Lukáš Hellebrandt 2020-02-14 14:41:52 UTC
FailedQA with Sat 6.7 snap 11. The options are shown in "hammer host create --help" and they work, except "preallocate" - that one is ignored (the created VM has actually a thin provisioned disk; this doesn't happen in WebUI).

Comment 10 Shira Maximov 2020-02-16 11:53:34 UTC
Added a new redmine issue and a new PR.

Comment 14 Lukáš Hellebrandt 2020-03-06 15:07:19 UTC
I can confirm that setting preallocate=1 causes the disk to indeed be preallocated (with Sat 6.7 snap 14). Once I check this information is included in snap 15 'hammer host create --help', I'll verify this BZ.

Comment 15 Lukáš Hellebrandt 2020-03-10 15:29:56 UTC
Verified with Sat 6.7 snap 15.

Comment 18 errata-xmlrpc 2020-04-14 15:54:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1455


Note You need to log in before you can comment on or make changes to this bug.