Bug 173903 - IMAP connection refused
IMAP connection refused
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
https://www.mydomain.com/webmail/src/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 08:41 EST by Clay Campbell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 10:29:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clay Campbell 2005-11-22 08:41:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Internally, it works and connects to IMAP dovecot.  When it is hit externally, it throws the IMAP connection refused error.  I've tried all types of things, hard-coding a imapServerAddress for example.  The really crazy part is I can't get that value show up changed in the error message displayed by squirrelmail.  Regardless of what set imapServerAddress, I always see

Error connecting to IMAP server: 127.0.0.1.
111 : Connection refused

I've tried /src/configtest.php, tried hardcoding a new imapServerAddress there at the fsocketopen call, still get the same 

ERROR: Error connecting to IMAP server "127.0.0.1:143".Server error: (111) Connection refused



Version-Release number of selected component (if applicable):
squirrelmail-1.4.6-0.cvs20050812.1.fc4.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.  Login to squirrelmail from outside the local IP range
2.  ERROR: Error connecting to IMAP server "127.0.0.1:143".Server error: (111) Connection refused
3.
  

Actual Results:  ERROR: Error connecting to IMAP server "127.0.0.1:143".Server error: (111) Connection refused

Expected Results:  user logged in, go about their squirrelmailing

Additional info:

Using dovecot.i386 0.99.14-4.fc4 for IMAP
Comment 1 Clay Campbell 2005-12-01 15:44:31 EST
Is this a bug, or am I not configuring one of these services correctly?  I
haven't heard anything from anyone, so I'm starting to wonder.  If it is likely
a configuration problem on my part please let me know so I can try fixing it
myself.  At this point I'm sorry I moved to core 4, because it looks like its
still a bit dicey.  Is there a better alternative for webmail that I can yum or
rpm install real quick?
Comment 2 Warren Togami 2005-12-01 21:09:39 EST
Other people are using it with no problem, so it is likely a configuration problem.

There is another issue that squirrelmail really sucks, it has many bugs and
seems to be at a near standstill upstream.  I am personally looking to have it
replaced and removed from a future Fedora.

If you want a really nice web based e-mail suite, try looking at zimbra.com.  It
is much more complicated than squirrelmail though, so it is a big question mark
right now whether we would ever be able to import it.  It itself is the entire
mail server or something.  Kind of scary.
Comment 3 Clay Campbell 2005-12-02 10:29:26 EST
Thanks Warren,

I was fubar the entire time.  I was being redirected by the router to a
depricated server with the same name.  Doh!

Thanks for your reply, it set me straight

I'm marking this notabug

C

Note You need to log in before you can comment on or make changes to this bug.