This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 173904 - Kernel hangs/reboots after "Write protecting the kernel read-only data"
Kernel hangs/reboots after "Write protecting the kernel read-only data"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 09:09 EST by Andy Burns
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 02:22:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
debug kernel log (13.67 KB, text/plain)
2005-11-22 09:09 EST, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2005-11-22 09:09:33 EST
Description of problem:


Version-Release number of selected component (if applicable):
2.6.14-1.1696_FC5smp

How reproducible:
Happens every time at boot up

Steps to Reproduce:
1. 
2.
3.
  
Actual results:

System sometimes reboots immediately, sometimes hangs for a couple of minutes
and then reoots, the last kernel logging is "Write protecting the kernel
read-only data"

Expected results:
Kernel starts successfully

Additional info:

FC4 instals and runs ok on this machine but didn't recognise onboard Intel e100
NIC) Hans Kristian Rosbach's "unofficial FC4.1" was new enough to install and
recognise the NIC and I could then yum it up to the latest FC4 patches without
problems.

tried BIOS settings for SATA drives as AHCI and IDE (installer seemed happy with
AHCI)

tried BIOS settings for ATA/IDE mode as Enhanced and Legacy (installer seemed
happy with enhanced)

tried BIOS settings for HT enabled and disabled (installer seemed happy with HT,
installed smp kernel)

Hardware Specs:
Intel D945GTP motherboard, BIOS v3191
P4 3GHz SL7Z9
Radeon X550 PCIe
2x 512MB 667MHz DDRII 4-4-4-12
2x WesternDig 250GB SATA
1x LiteOn DVD-RW LDW-411S
2x Compro Videomate DVB-T200 tuners
Comment 1 Andy Burns 2005-11-22 09:09:36 EST
Created attachment 121348 [details]
debug kernel log
Comment 2 Andy Burns 2005-11-22 20:21:04 EST
Thanks to davej for the suggestion to boot with the kernel option
"mem=nopentium" which acts as a workaround, also in future kernels >=
2.6.14-1.1707_FC5 try the "nowprodata" kernel option which disables the write
protection.

Comment 3 Dave Jones 2005-12-01 02:22:23 EST
should now work in rawhide without any special boot options at all.

Note You need to log in before you can comment on or make changes to this bug.