Bug 1739085 - Multi-version CRDs and admission webhooks do not play nicely together in OpenShift 4.1
Summary: Multi-version CRDs and admission webhooks do not play nicely together in Open...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.z
Assignee: Stefan Schimanski
QA Contact: scheng
URL:
Whiteboard:
Depends On: 1739235
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-08 13:08 UTC by Paul Morie
Modified: 2019-08-28 19:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1739235 (view as bug list)
Environment:
Last Closed: 2019-08-28 19:54:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23580 None closed Bug 1739085: Fix multi-version CRD and admission webhook 2020-04-15 07:52:17 UTC
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:54:59 UTC

Description Paul Morie 2019-08-08 13:08:02 UTC
Description of problem:

When multiple versions of a CRD is declared, and webhooks for that resource exist, sometimes create/update operations will fail with an error like:

See upstream issue: https://github.com/kubernetes/kubernetes/issues/73752

A fix for this issue was recently merged upstream to the release-1.13 branch: https://github.com/kubernetes/kubernetes/pull/79495

We have applied this patch to the openshift release-4.1 branch and established that this appears to fix the issue on 4.1.

It is critical in order to run Knative on OpenShift 4.1 that this bug be included in the next z-stream release.

Version-Release number of selected component (if applicable):

4.1

How reproducible:

Intermittent; required restart of API server pod in order to reliably trigger

Steps to Reproduce:
1. Create a CRD with multiple versions
2. Create an admission webhook for the resource
3. Create/update the resource

Actual results:

Error from server (InternalError): Internal error occurred: no kind "Service" is registered for version "serving.knative.dev/v1beta1" in scheme "k8s.io/apiextensions-apiserver/pkg/apiserver/apiserver.go:62"

Expected results:

Updates should result in admission webhook being triggered / normal admission flow.


Additional info:

Comment 2 scheng 2019-08-21 11:33:29 UTC
Following https://bugzilla.redhat.com/show_bug.cgi?id=1739235#c2 steps,no such issue found.

# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-08-21-023728   True        False         2m47s   Cluster version is 4.1.0-0.nightly-2019-08-21-023728

Comment 4 errata-xmlrpc 2019-08-28 19:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.