Bug 1739219 - [4.1.z] Image Registry's service CA is constantly removed/re-created
Summary: [4.1.z] Image Registry's service CA is constantly removed/re-created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.z
Assignee: Adam Kaplan
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On: 1734564
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-08 18:48 UTC by Adam Kaplan
Modified: 2019-08-28 19:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: CVO, the image-registry-operator, and the service-ca injection controller simultaneously watched and updated the CA bundle used by the image registry. Consequence: The CA bundle used to establish trust between the internal registry and the rest of OpenShift was constantly removed re-created. Fix: CVO no longer manages the CA bundle. The image registry operator ensures the ConfigMap to hold the CA bundle is created, but does not manage its content. Result: The ConfigMap holding the CA bundle for the internal registry is only updated as needed by the service-ca injection controller.
Clone Of: 1734564
Environment:
Last Closed: 2019-08-28 19:54:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:54:59 UTC
Github openshift cluster-image-registry-operator pull 359 None None None 2019-08-20 14:07:36 UTC

Description Adam Kaplan 2019-08-08 18:48:31 UTC
+++ This bug was initially created as a clone of Bug #1734564 +++

Description of problem:

The image registry operator creates a ConfigMap to inject the CA for the internal registry service. This CA is constantly wiped out by the CVO, only to be re-created by the ca-configmap-injector. 

How reproducible: Always


Steps to Reproduce:
1. Watch `oc get cm serviceca -n openshift-image-registry -o yaml`

Actual results:

Data is regularly removed/recreated (every 10 minutes or less), and revision number increases over time.


Expected results:

Data and revision number of the service CA is stable.

Comment 2 Wenjing Zheng 2019-08-23 07:41:41 UTC
Verified in 4.1.0-0.nightly-2019-08-21-150150.

Comment 4 errata-xmlrpc 2019-08-28 19:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.