Bug 173922 - broken "set terminal png small size 300,200"
broken "set terminal png small size 300,200"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnuplot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
http://www.herrold.com/gnuplot/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 13:04 EST by R P Herrold
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 06:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testing .spec file (3.88 KB, text/plain)
2005-11-22 13:04 EST, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2005-11-22 13:04:06 EST
Hi,  Phil, et al.

reference bugs 172565  170497 

The 'size x,y' is not supported in the existing RH build approach

You commented:

PS: The documented "size x,y" for png terminals doesn't seem to work at the
moment or isn't detected properly by gnuplot (which would have been the best way
to solve this).

===================================

After some testing, it turns out this is an (completely reproduceable and
fixable) artifact of the ./configure option:  
    --without-gd

in both the RawHide 4.0, and against the CVS which will become 4.1

Solution is to omit that line, and to add a:

BuildRequires: gd-devel

test cases available -- I attached my testing .spec file
Comment 1 R P Herrold 2005-11-22 13:04:08 EST
Created attachment 121364 [details]
testing .spec file
Comment 2 R P Herrold 2005-11-22 13:28:29 EST
data used in testing
Comment 3 Hans de Goede 2005-11-30 09:38:18 EST
This bug doesnot seem to be about gnumeric but about gnuplot,

Coalan, Next time you might try reading the bug before reasigning to me :)
Feel free to remove yourself from the CC again.

Appearantly the reported accidently clicked on gnumeric as component instead of
on gnuplot.

Changing component to gnuplot.
Comment 4 José Matos 2006-01-25 11:53:05 EST
This bug is related with 172565. I propose to close as it 
as duplicated. 
 
The behaviour of the old drive is really disappointing, 
Fixed size png and not possibility to crop them. :-( 
Comment 5 R P Herrold 2006-07-14 22:53:28 EDT
packaging maintainer pinged on 172565 for the common fix needed
Comment 6 Ivana Varekova 2006-12-21 06:32:02 EST
Fixed in gnuplot-4.0.0-14.fc7.

Note You need to log in before you can comment on or make changes to this bug.