Bug 1739224 - Stack update fails while running podman exec --user=root keystone /usr/bin/bootstrap_host_exec keystone keystone-manage bootstrap --bootstrap-password with stderr: cannot exec into container that is not running: container state improper
Summary: Stack update fails while running podman exec --user=root keystone /usr/bin/bo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-paunch
Version: 15.0 (Stein)
Hardware: All
OS: All
high
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Steve Baker
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-08 19:09 UTC by Marius Cornea
Modified: 2019-11-11 20:31 UTC (History)
11 users (show)

Fixed In Version: python-paunch-4.5.1-0.20190829080435.f9349e0.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:24:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1839559 0 None None None 2019-08-08 22:46:57 UTC
Launchpad 1839841 0 None None None 2019-08-12 19:03:36 UTC
Launchpad 1839929 0 None None None 2019-08-14 16:08:45 UTC
OpenStack gerrit 676749 0 'None' MERGED Fix systemd service start rate limiting 2020-10-05 05:08:02 UTC
OpenStack gerrit 676984 0 'None' MERGED Fix mismatching fixed vs unique container names 2020-10-05 05:08:02 UTC
OpenStack gerrit 677774 0 'None' ABANDONED runner: return True to check if image/container exists 2020-10-05 05:08:02 UTC
OpenStack gerrit 677860 0 'None' MERGED Check if container is running before doing an exec 2020-10-05 05:08:02 UTC
OpenStack gerrit 678071 0 'None' MERGED Check if container is running before doing an exec 2020-10-05 05:08:02 UTC
RDO 21907 0 None master: MERGED rdoinfo: stein/paunch: force to build on old commit (I2cf11cef10d623753239aad61d8a0032965f69a6) 2019-08-22 11:06:54 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:41 UTC

Description Marius Cornea 2019-08-08 19:09:52 UTC
Description of problem:

Running stack update(noop or for scaling out) fails while running podman exec --user=root keystone /usr/bin/bootstrap_host_exec keystone keystone-manage bootstrap --bootstrap-password with stderr: cannot exec into container that is not running: container state improper:

        "Running container: keystone_bootstrap",
        "$ podman ps -a --filter label=container_name=keystone --filter label=config_id=tripleo_step3 --format {{.Names}}",
        "b'keystone\\n'",
        "$ podman exec --user=root keystone /usr/bin/bootstrap_host_exec keystone keystone-manage bootstrap --bootstrap-password hSWHWHHeD2HgCVqprTITYMZCB",
        "b'cannot exec into container that is not running: container state improper\\n'",
        "Error running ['podman', 'exec', '--user=root', 'keystone', '/usr/bin/bootstrap_host_exec', 'keystone', 'keystone-manage', 'bootstrap', '--bootstrap-password', 'hSWHWHHeD2HgCVqprTITYMZCB']. [126]",
        "stderr: cannot exec into container that is not running: container state improper",
        "Running container: nova_db_sync",
        "Skipping existing container: nova_db_sync",
        "Running container: keystone_cron",
        "Skipping existing container: keystone_cron"

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-10.6.1-0.20190806190500.bdcffcd.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
2. Re-run overcloud deploy

Actual results:
Fails while running podman exec --user=root keystone /usr/bin/bootstrap_host_exec keystone keystone-manage bootstrap --bootstrap-password

Expected results:
No failure.

Additional info:
Attaching jobs artifacts.

Comment 24 Marius Cornea 2019-08-31 00:47:52 UTC
I ran multiple stack updates without reproducing the issue reported initially.

Comment 28 errata-xmlrpc 2019-09-21 11:24:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.