Bug 173926 - Support list and service match in pam_succeed_if
Support list and service match in pam_succeed_if
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Jay Turner
:
: 176423 229755 (view as bug list)
Depends On: 165571
Blocks: 176344 198694
  Show dependency treegraph
 
Reported: 2005-11-22 13:23 EST by Chris Kloiber
Modified: 2015-01-07 19:11 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2007-0300
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Jason Vas Dias 2006-01-17 14:41:10 EST
*** Bug 176423 has been marked as a duplicate of this bug. ***
Comment 6 RHEL Product and Program Management 2006-08-18 12:57:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Jay Turner 2006-08-29 16:12:42 EDT
QE ack for 4.5.  Need another bug to track the authconfig changes necessary.
Comment 8 Tomas Mraz 2006-09-20 02:53:07 EDT
After more thinking about this bug I think it should be closed as NEXTRELEASE.

The bug is workarounded in current RHEL4 crond PAM config file by not including
system-auth for session. It is also fixed properly in FC6/RHEL5.

Or we could just enhance pam_succeed_if with service matching support which
could be handy and leave the authconfig and crond (because the workaround would
have to be reverted) changes for next update.
Comment 17 Tomas Mraz 2007-02-23 06:21:35 EST
*** Bug 229755 has been marked as a duplicate of this bug. ***
Comment 18 John Robinson 2007-02-23 06:51:02 EST
I can't see most of the comments on this bug, but my bug #229755 is not about
pam_unix spamming /var/log/messages on cron jobs, it is about a feature of PAM
not working correctly, or being absent from EL4's PAM build and misreporting the
issue.
Comment 19 Tomas Mraz 2007-02-23 07:12:18 EST
The bug morphed a little bit since the original report. Changing the summary to
reflect what is planned be done for RHEL4.5.
Comment 21 Red Hat Bugzilla 2007-05-01 13:22:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0300.html

Note You need to log in before you can comment on or make changes to this bug.