Bug 17393 - rpm --rebuild glibc-2.1.3-19.src.rpm --> no _start
Summary: rpm --rebuild glibc-2.1.3-19.src.rpm --> no _start
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-10 14:22 UTC by Sami Farin
Modified: 2016-11-24 15:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 09:08:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sami Farin 2000-09-10 14:22:35 UTC
what went wrong?

[/usr/lib]$ nm crt1.o 
nm: crt1.o: no symbols

I have gcc-2.95.2, binutils-2.10, redhat 5.0+many updates.
I have compiled glibc many times, but this is the first time crt*.o broke.

now I installed glibc-2.1.3-21 rpms from Redhat and they seem to work. 

however, if I compile cdrdao-1.1.4 and run it, it segfaults. gdb shows:

#0  __pthread_mutex_lock (mutex=0x0) at mutex.c:82
#1  0x2aad5c2b in __flockfile (stream=0x80b8cc0) at lockfile.c:32
#2  0x2ab5d760 in buffered_vfprintf (s=0x80b8cc0, format=0x8097e83 "",
args=0x7fffe758)
    at vfprintf.c:1762
#3  0x2ab58966 in _IO_vfprintf (s=0x80b8cc0, format=0x8097e83 "",
ap=0x7fffe758) at vfprintf.c:1029
#4  0x804b9e8 in message (level=0, 
    fmt=0x804b801 "t", '\220' <repeats 14 times>,
"U\211e\203l\b\203=h<\n\b") at main.cc:258
#5  0x2ab2b9cb in __libc_start_main (main=0x804ebb0 <main>, argc=1,
argv=0x7fffe8b4, 
    init=0x804ad68 <_init>, fini=0x8097c6c <_fini>, rtld_fini=0x2aab5e60
<_dl_fini>, 
    stack_end=0x7fffe8ac) at ../sysdeps/generic/libc-start.c:92

I don't know what's broken... is this related to the mutex fix/change in
glibc?

cdrdao binary from cdrdao homepage works ok.

Comment 1 Sami Farin 2000-09-10 16:11:51 UTC
I forgot to tell one more prob I had with self-compiled 2.1.3-19.
cdrecord failed with 

cdrecord: Input/output error. send opc: scsi sendcmd: retryable error
status: 0x0 (GOOD STATUS)
CDB:  54 01 00 00 00 00 00 00 00 00
cdrecord: Resource temporarily unavailable. OPC failed.

after upgrading to glibc-2.1.3-21, cdrecord works ok.

what could cause this kind of behaviour?


Comment 2 Ulrich Drepper 2003-04-22 00:42:15 UTC
This is for an very old glibc version.  If you have the same problem with RHL9
we'd like to hear about it.  Otherwise I'll close the bug soon.

Comment 3 Ulrich Drepper 2003-10-03 09:08:09 UTC
No reply in almost six months.  Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.