Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1739443 - lscpu reports wrong hypervisor in nested virt on s390x
Summary: lscpu reports wrong hypervisor in nested virt on s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: util-linux
Version: 8.0
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: Karel Zak
QA Contact: Radka Skvarilova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-09 10:27 UTC by Dan Horák
Modified: 2020-04-28 17:03 UTC (History)
0 users

Fixed In Version: util-linux-2.32.1-18.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 17:03:07 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
/proc + /sys dump (7.03 KB, application/gzip)
2019-08-09 10:27 UTC, Dan Horák
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github karelzak/util-linux/commit/350f5c8df2cb6edbfb5bae95f00a9fff446d236c 0 None None None 2020-06-10 06:55:42 UTC
Github karelzak util-linux pull 871 0 'None' closed tests: lscpu s390 nested virtualization 2020-06-10 06:55:42 UTC
Red Hat Product Errata RHBA-2020:1908 0 None None None 2020-04-28 17:03:09 UTC

Description Dan Horák 2019-08-09 10:27:46 UTC
Created attachment 1602074 [details]
/proc + /sys dump

Description of problem:
lscpu incorrectly reports z/VM as hypervisor while it should report KVM. It's for HW -> z/VM guest -> KVM guest nested virt scenario.

Version-Release number of selected component (if applicable):
util-linux-2.32.1-8.el8.s390x

How reproducible:
100%

Steps to Reproduce:
1. install KVM guest on top of a z/VM guest
2. lspcu in KVM guest

Actual results:
Architecture:        s390x
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Big Endian
CPU(s):              2
On-line CPU(s) list: 0,1
Thread(s) per core:  1
Core(s) per socket:  1
Socket(s) per book:  1
Book(s) per drawer:  1
Drawer(s):           2
NUMA node(s):        1
Vendor ID:           IBM/S390
Machine type:        2964
CPU dynamic MHz:     5000
CPU static MHz:      5000
BogoMIPS:            3033.00
Hypervisor:          z/VM 6.4.0
Hypervisor vendor:   IBM
Virtualization type: full
Dispatching mode:    horizontal


Expected results:
Architecture:                    s390x
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Big Endian
CPU(s):                          2
On-line CPU(s) list:             0,1
Thread(s) per core:              1
Core(s) per socket:              1
Socket(s) per book:              1
Book(s) per drawer:              1
Drawer(s):                       2
NUMA node(s):                    1
Vendor ID:                       IBM/S390
Machine type:                    2964
CPU dynamic MHz:                 5000
CPU static MHz:                  5000
BogoMIPS:                        3033.00
Hypervisor:                      KVM/Linux
Hypervisor vendor:               KVM


Additional info:
fixed in upstream with https://github.com/karelzak/util-linux/commit/350f5c8df2cb6edbfb5bae95f00a9fff446d236c

Comment 5 errata-xmlrpc 2020-04-28 17:03:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1908


Note You need to log in before you can comment on or make changes to this bug.