Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1739603 - [4.1.z] static pods are subject to eviction
Summary: [4.1.z] static pods are subject to eviction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.z
Assignee: Seth Jennings
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On: 1739601
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-09 15:43 UTC by Seth Jennings
Modified: 2019-09-12 18:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes and issue where critical static pods are not recognized as critical by the kubelet because they are not assigned a priority value by the admission plugin on the API server because static pods are not admitted via the API server. The issue is resolved by treating all static pods as critical. Cluster admins should ensure that nodes have sufficient resources for these pods to run as they bypass the schedule resource checks and will evict workloads in case of overcommitment.
Clone Of: 1739601
Environment:
Last Closed: 2019-09-12 18:56:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 23584 0 None None None 2019-08-15 13:08:38 UTC
Red Hat Product Errata RHBA-2019:2681 0 None None None 2019-09-12 18:56:19 UTC

Description Seth Jennings 2019-08-09 15:43:11 UTC
+++ This bug was initially created as a clone of Bug #1739601 +++

upstream fix
https://github.com/kubernetes/kubernetes/pull/80491

Comment 1 Seth Jennings 2019-08-12 21:57:10 UTC
Waiting on https://bugzilla.redhat.com/show_bug.cgi?id=1739601 to be VERIFIED

origin PR:
https://github.com/openshift/origin/pull/23584

Comment 10 errata-xmlrpc 2019-09-12 18:56:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2681


Note You need to log in before you can comment on or make changes to this bug.