Bug 173978 - Can't rebuild xorg-x11-6.8.2-1.EL.13.20
Can't rebuild xorg-x11-6.8.2-1.EL.13.20
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 06:54 EST by Axel Thimm
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 07:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2005-11-23 06:54:43 EST
Description of problem:
I want to add some functionality to xorg-x11, and I couldn't rebuilt the patched
src.rpm. I then tried with the original one and failed, too. The build host is
an updated RHEL4U2.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.EL.13.20

How reproducible:
always

Steps to Reproduce:
1.Install xorg-x11-6.8.2-1.EL.13.20.src.rpm
2.rpmbuild
3.
  
Actual results:
rm -f scanpci
gcc -m32 -o scanpci -O2  -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32
-march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -fno-strict-aliasing
-pipe -ansi -pedantic -Wall -Wpointer-arith -Wundef    
-L../../../../../exports/lib   scanpci.o -L../os-support -lxf86_os -L../scanpci
-lscanpci -L../dummylib -ldummy       -Wl,-rpath-link,../../../../../exports/lib
../os-support/libxf86_os.a(libc_wrapper.o)(.text+0x182d): In function
`xf86getpagesize':
: multiple definition of `xf86getpagesize'
scanpci.o(.text+0x1a41): first defined here
/usr/bin/ld: Warning: size of symbol `xf86getpagesize' changed from 10 in
scanpci.o to 103 in ../os-support/libxf86_os.a(libc_wrapper.o)
../os-support/libxf86_os.a(libc_wrapper.o)(.text+0x1561): In function `xf86sqrt':
: undefined reference to `sqrt'
../os-support/libxf86_os.a(libc_wrapper.o)(.text+0x5): In function `xf86hypot':
: undefined reference to `hypot'
../os-support/libxf86_os.a(libc_wrapper.o)(.text+0xd7): In function `xf86strlcat':
: undefined reference to `strlcat'
[...]

Expected results:


Additional info:
Maybe the glibc update in RHEL4U2 is causing the trouble?
Thanks!
Comment 1 Mike A. Harris 2005-11-23 07:57:56 EST
For official Red Hat Enterprise Linux support, please log into the Red Hat
support website at http://www.redhat.com/support and file a support ticket,
or alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1
to speak directly with a support associate and escalate an issue.

If you require technical assistance for rpm package development related
issues, another avenue that might be useful is rpm-list@redhat.com

Hope this helps.

Setting status to "NOTABUG"
Comment 2 Axel Thimm 2005-11-24 01:01:50 EST
Thanks Mike, but I think you read over the bug report a bit too fast.

The issue is not "how do I patch up a src.rpm", but that the *original
unaltered* src.rpm for RHEL4U2 does not build on RHEL4U2.

It isn't NOTABUG, if the reprocability of the build isn't important at this time
 I suggest to make that WONTFIX. Although a fix would be most welcome.

FWIW the rebuild on x86_64 has a different failure when collecting pieces in
%files, while FC4 and FC3 src.rpms build OK in their native environment for both
i386 and x86_64.
Comment 3 Mike A. Harris 2005-11-29 04:21:44 EST
The package we shipped in U2 was built with U2.  It rebuilds on all 7
architectures on U2 presently, and it rebuilds on U2 installed on 2 machines
locally, as well as on FC4 and rawhide.

This is not a "WONTFIX" issue, it really is "NOTABUG".

You are having a local compilation issue.  Try reinstalling your OS, and
removing ccache or other things that might affect the output of your compile.
If you continue to have problems, please feel free to use Red Hat or X.Org
mailing lists to assist you in determining the root cause of your problem.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.