Bug 173980 - pear makerpm fails to handle docs in root directory
pear makerpm fails to handle docs in root directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On: 176725
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 07:42 EST by Tim Jackson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: php-pear-1.4.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 09:18:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix against php-pear-5.0.4 included with FC4 (1.13 KB, patch)
2005-11-23 07:42 EST, Tim Jackson
no flags Details | Diff
updated patch that actually works (1.13 KB, patch)
2005-11-23 08:15 EST, Tim Jackson
no flags Details | Diff

  None (edit)
Description Tim Jackson 2005-11-23 07:42:45 EST
Description of problem:
"pear makerpm" does not always produce spec files that build.
Upstream bug http://pear.php.net/bugs/bug.php?id=6047 has been filed, which
includes a patch backported to PEAR 1.3.5 (which is included with  
php-pear-5.0.4-10.5).

Full details are in the upstream bug and are not reproduced here  (though can be
if it helps). The patch (against FC) which fixes the issue is attached to this bug.
Comment 1 Tim Jackson 2005-11-23 07:42:48 EST
Created attachment 121393 [details]
fix against php-pear-5.0.4 included with FC4
Comment 2 Tim Jackson 2005-11-23 08:15:19 EST
Created attachment 121394 [details]
updated patch that actually works

sorry, 1-char typo in previous patch
Comment 3 Tim Jackson 2005-11-27 06:48:09 EST
Fix has been accepted into CVS upstream.
Comment 4 Tim Jackson 2006-01-11 10:18:52 EST
There is now an upstream PEAR 1.4.6 release which includes this fix. So a build
of PEAR 1.4.6 will close this bug.

Note You need to log in before you can comment on or make changes to this bug.