Bug 17399 - gnome-terminal incorrect URL highlighting
gnome-terminal incorrect URL highlighting
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-10 17:23 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-11 15:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 2000-09-10 17:23:13 EDT
gnome-terminal highlight an URL (shown in the terminal as underlined text).
The problem is that it does not do this correctly
in case URL has % symbol in it.
If you type in prompt
http://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=aaa
and move mouse to this line the entire URL will be highlighted
but if you type
http://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=aaa%60&a=b&c=d
the symbols after % are just ignored, what is incorrect.
% is a standard way to encode symbols in URL.

Another thing, the URL is shown as it possible to click on it,
but if I click nothing happens.
Should a web browser be started?
Comment 1 Havoc Pennington 2000-09-10 23:40:30 EDT
Probably we just need to add % to the regular expression used to parse URLs in
gnome-terminal.c. You should be able to right-click on a URL to open it.
Comment 2 Nalin Dahyabhai 2000-09-11 15:49:17 EDT
A plain rightclick doesn't always work, but ctrl+rightclick does.
Comment 3 Elliot Lee 2001-01-31 20:02:28 EST
This has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.