Bug 173991 - initscripts not LSB-compliant, breaking cluster suite
initscripts not LSB-compliant, breaking cluster suite
Status: CLOSED DUPLICATE of bug 151104
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 09:40 EST by Nick Strugnell
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 11:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2005-11-23 09:40:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.7.12-1.1.3.2

Description of problem:
The initscripts shipped with RHEL4 do not have LSB-compliant behaviour, and therefore break cluster suite.

Clustersuite expects the following behaviour:-

1. If the 'start' method is called when the service is already running, the init script should return success.

2. If the 'stop' method is called when the service is not running, the init scripts should return success.

This is the defined behaviour according to LSB 1.3 (http://www.linuxbase.org/spec/refspecs/LSB_1.3.0/gLSB/gLSB/iniscrptact.html)

Example init scripts that do not follow this behaviour:

httpd, smb do not observe behaviour 2.
nsdcd does not observe behaviour 1.

Some scripts (e.g. pam) do seem to be compliant.

This bug is particularly bad as the walkthrough documentation for RHCS at http://www.redhat.com/docs/manuals/csgfs/browse/rh-cs-en/ch-httpd-service.html uses httpd as an example - this will not work.

Version-Release number of selected component (if applicable):
initscripts-7.93.20.EL-1

How reproducible:
Always

Steps to Reproduce:
1. service httpd start
2. service httpd stop 
3. service httpd stop
4. echo $?
  

Actual Results:  1

Expected Results:  0

Additional info:

I'm putting this to a severity of high as it seriously compromises the availability of HA clusters.
Comment 1 Nick Strugnell 2005-11-23 09:42:28 EST
Blah, where I say 'some scripts (e.g. pam) seem to be compliant' I meant gpm
Comment 2 Nick Strugnell 2005-11-23 11:56:02 EST

*** This bug has been marked as a duplicate of 151104 ***
Comment 3 Bill Nottingham 2005-11-23 12:35:37 EST
Note that scripts shipped with the OS are not required to be LSB compliant.
Comment 4 Nick Strugnell 2005-11-23 12:56:53 EST
While scripts shipped with the OS are not required to be LSB compliant, our
clients might reasonably expect them to actually work with Red Hat Cluster suite.

Note You need to log in before you can comment on or make changes to this bug.