Bug 1739915 - olpc-update fails to install in Fedora rawhide
Summary: olpc-update fails to install in Fedora rawhide
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: olpc-update
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Daniel Drake
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2FTBI F31FailsToInstall SugarOnPy3 F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-08-11 21:30 UTC by Miro Hrončok
Modified: 2019-11-18 14:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 14:09:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-08-11 21:30:55 UTC
olpc-update-2.29-12.fc31.noarch fails to install in Fedora rawhide:

  nothing provides bitfrost needed by olpc-update-2.29-12.fc31.noarch
  nothing provides olpc-contents needed by olpc-update-2.29-12.fc31.noarch

This is most likely caused by a dependency that was retired.
Please drop the dependency, unretire the dependency or remove the package. Thanks

Comment 1 Ben Cotton 2019-08-13 16:48:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Miro Hrončok 2019-08-21 15:46:59 UTC
See https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

"Packages still failing to install due to a missing Python 2 dependency will be retired at Beta Freeze, assuming they have a Bugzilla bug open for at least 2 weeks. The package maintainer may postpone this retirement to the Final Freeze by promising to fix it until then."

Let me know if this package shall not be retired yet. The beta freeze is at 2019-08-29, the final freeze is at 2019-10-08.

Comment 3 Miro Hrončok 2019-08-26 12:04:34 UTC
Will postpone the retirement to the Final Freeze based on the mailing list discussion with Peter: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/A5NTIBGL6PYGLFGPC7W4H4UVOVPVKMJM/


Note You need to log in before you can comment on or make changes to this bug.