Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1739916 - puddletag fails to install in Fedora rawhide
Summary: puddletag fails to install in Fedora rawhide
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: puddletag
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall PY2FTBI
TreeView+ depends on / blocked
 
Reported: 2019-08-11 21:31 UTC by Miro Hrončok
Modified: 2019-09-22 11:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-22 11:30:13 UTC
Type: Bug


Attachments (Terms of Use)
Fix FTBFS (2.76 KB, patch)
2019-08-12 17:10 UTC, Terje Røsten
no flags Details | Diff

Description Miro Hrončok 2019-08-11 21:31:17 UTC
puddletag-1.2.0-9.fc31.noarch fails to install in Fedora rawhide:

  nothing provides python2-musicbrainz2 needed by puddletag-1.2.0-9.fc31.noarch

This is most likely caused by a dependency that was retired.
Please drop the dependency or remove the package. Thanks

Comment 1 Terje Røsten 2019-08-12 05:20:54 UTC
hmm, porting puddletag to Python 3 is non-trivial, and now it seems time to port it is just a few days?
This seems a bit strange.

Comment 2 Miro Hrončok 2019-08-12 09:17:30 UTC
What seems a bit strange? Your dependency is gone. That happens. I don't understand the question, sorry.

Comment 3 Petr Viktorin 2019-08-12 10:37:09 UTC
Another option is to claim python-musicbrainz2 back, and fix it. I don't know how involved that would be; the last successful build was for Fedora 28.

Comment 4 Terje Røsten 2019-08-12 17:09:53 UTC
Ok, maybe I am understanding these, this is generic thingie not removable of all Python 2 modules. 

Fixing  musicbrainz2 with work with Python was trivial:
 https://koji.fedoraproject.org/koji/taskinfo?taskID=36965998

Patch against latest build attached.

Comment 5 Terje Røsten 2019-08-12 17:10:59 UTC
Created attachment 1602992 [details]
Fix FTBFS

Fix build in rawhide for Python 2, no Python 3 support yet.

Comment 6 Ben Cotton 2019-08-13 17:04:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Ben Cotton 2019-08-13 17:10:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 8 Miro Hrončok 2019-08-21 15:47:14 UTC
See https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

"Packages still failing to install due to a missing Python 2 dependency will be retired at Beta Freeze, assuming they have a Bugzilla bug open for at least 2 weeks. The package maintainer may postpone this retirement to the Final Freeze by promising to fix it until then."

Let me know if this package shall not be retired yet. The beta freeze is at 2019-08-29, the final freeze is at 2019-10-08.

Comment 9 Miro Hrončok 2019-08-28 12:01:31 UTC
I was about to retire the package now. Terje, what is the status?

Comment 10 Terje Røsten 2019-08-29 06:15:54 UTC
package can be retired.

Comment 11 Miro Hrončok 2019-08-29 08:31:47 UTC
Done.

Comment 12 Miro Hrončok 2019-08-30 11:57:52 UTC
Requesting a freeze exception based on https://pagure.io/fesco/issue/2216#comment-593925

Comment 13 Adam Williamson 2019-08-30 16:08:49 UTC
Unproposing per https://pagure.io/fesco/issue/2216#comment-594033 . Please only propose bugs where an update was actually pending before the 29th, unless there is a more urgent reason why that package specifically should get an FE.

Comment 14 Miro Hrončok 2019-09-22 11:30:13 UTC
Automation has figured out the package is retired in Fedora 31.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.