Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1739928 - python2-tw2-jqplugins-ui fails to install in Fedora rawhide
Summary: python2-tw2-jqplugins-ui fails to install in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-tw2-jqplugins-ui
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException
Depends On:
Blocks: F31FailsToInstall PY2FTBI
TreeView+ depends on / blocked
 
Reported: 2019-08-11 21:33 UTC by Miro Hrončok
Modified: 2019-09-14 16:31 UTC (History)
2 users (show)

Fixed In Version: python-tw2-jqplugins-ui-2.3.0-8.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-14 00:07:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-08-11 21:33:39 UTC
python2-tw2-jqplugins-ui-2.3.0-6.fc31.noarch fails to install in Fedora rawhide:

  nothing provides python2.7dist(tw2.core) >= 2.0b5 needed by python2-tw2-jqplugins-ui-2.3.0-6.fc31.noarch
  nothing provides python2-tw2-core needed by python2-tw2-jqplugins-ui-2.3.0-6.fc31.noarch

This is most likely caused by a dependency that was retired.
Please drop the dependency or remove the package. Thanks

Comment 1 Ben Cotton 2019-08-13 16:48:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Miro Hrončok 2019-08-21 15:47:07 UTC
See https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

"Packages still failing to install due to a missing Python 2 dependency will be retired at Beta Freeze, assuming they have a Bugzilla bug open for at least 2 weeks. The package maintainer may postpone this retirement to the Final Freeze by promising to fix it until then."

Let me know if this package shall not be retired yet. The beta freeze is at 2019-08-29, the final freeze is at 2019-10-08.

Comment 3 Miro Hrončok 2019-08-28 12:35:02 UTC
This doesn't build, so I cannot remove the subpackage. I suppose I need to live with the rawhide retirement instead.

Comment 4 Fedora Update System 2019-08-28 22:14:53 UTC
FEDORA-2019-b652178dad has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b652178dad

Comment 5 Miro Hrončok 2019-08-30 11:59:14 UTC
Requesting a freeze exception based on https://pagure.io/fesco/issue/2216#comment-593925

Comment 6 Fedora Update System 2019-08-30 12:17:15 UTC
python-tw2-jqplugins-ui-2.3.0-8.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b652178dad

Comment 7 Geoffrey Marr 2019-09-03 21:43:49 UTC
Discussed during the 2019-09-03 blocker review meeting: [1]

The decision to classify this bug as a "RejectedFreezeException" was made as this is not on any of the release media, so we can just leave the update process to handle it. Note it was not submitted for stable before the old freeze date.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-03/f31-blocker-review.2019-09-03-16.01.txt

Comment 8 Fedora Update System 2019-09-14 00:07:01 UTC
python-tw2-jqplugins-ui-2.3.0-8.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-09-14 16:31:09 UTC
python-tw2-jqplugins-ui-2.3.0-8.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.