Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1740004 - [GCP] "oc get machine" does not show machine's TYPE/REGION/ZONE
Summary: [GCP] "oc get machine" does not show machine's TYPE/REGION/ZONE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Michael Gugino
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-12 05:29 UTC by Jianwei Hou
Modified: 2019-10-16 06:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:35:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-gcp pull 48 0 None closed bug 1740004: Set additional machine annotations/labels to get pretty machine output 2020-04-10 06:41:08 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:35:46 UTC

Description Jianwei Hou 2019-08-12 05:29:52 UTC
Description of problem:
On GCP IPI, `oc get machines -n openshift-machine-api`. The TYPE, REGION, ZONE columns do not have values

NAME                   INSTANCE               STATE     TYPE   REGION   ZONE   AGE
jhou-bttbb-m-0         jhou-bttbb-m-0         RUNNING                          54m
jhou-bttbb-m-1         jhou-bttbb-m-1         RUNNING                          54m
jhou-bttbb-m-2         jhou-bttbb-m-2         RUNNING                          54m
jhou-bttbb-w-a-767hc   jhou-bttbb-w-a-767hc   RUNNING                          52m
jhou-bttbb-w-b-884jb   jhou-bttbb-w-b-884jb   RUNNING                          52m
jhou-bttbb-w-c-nw66w   jhou-bttbb-w-c-nw66w   RUNNING                          52m


For each machine(oc get machine -o json), in their spec.providerSpec.value, the TYPE, REGION, ZONE has the desired value.

oc get machines -n openshift-machine-api -o=jsonpath='{range .items[*]}{.metadata.name}{"\t"}{.spec.providerSpec.value.machineType}{"\t"}{.spec.providerSpec.value.region}{"\t"}{.spec.providerSpec.value.zone}{"\n"}'
jhou-bttbb-m-0	n1-standard-4	us-central1	us-central1-a
jhou-bttbb-m-1	n1-standard-4	us-central1	us-central1-b
jhou-bttbb-m-2	n1-standard-4	us-central1	us-central1-c
jhou-bttbb-w-a-767hc	n1-standard-4	us-central1	us-central1-a
jhou-bttbb-w-b-884jb	n1-standard-4	us-central1	us-central1-b
jhou-bttbb-w-c-nw66w	n1-standard-4	us-central1	us-central1-c



Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-08-08-103722

How reproducible:
Always

Steps to Reproduce:
As description

Actual results:
TYPE, REGION, ZONE should have values

Expected results:


Additional info:

Comment 1 Jan Chaloupka 2019-08-13 12:37:11 UTC
The required step here is to have gcp actuator to set additional labels and annotations. Although it's not a blocker for properly working machine plane on GCP, it's nice to have all the columns set. The work to fix the issue is already scheduled for this sprint.

Comment 3 sunzhaohua 2019-08-22 07:46:46 UTC
Verified

$ oc get machine
NAME                     STATE     TYPE            REGION        ZONE            AGE
qitang-6vnjx-m-0         RUNNING   n1-standard-4   us-central1   us-central1-a   7h9m
qitang-6vnjx-m-1         RUNNING   n1-standard-4   us-central1   us-central1-b   7h9m
qitang-6vnjx-m-2         RUNNING   n1-standard-4   us-central1   us-central1-c   7h9m
qitang-6vnjx-w-a-wwjcf   RUNNING   n1-standard-4   us-central1   us-central1-a   7h8m
qitang-6vnjx-w-b-9rrv9   RUNNING   n1-standard-4   us-central1   us-central1-b   7h8m
qitang-6vnjx-w-c-5cxlk   RUNNING   n1-standard-4   us-central1   us-central1-c   7h8m

Comment 4 errata-xmlrpc 2019-10-16 06:35:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.