Bug 1740035 - [IPI on Azure]Status.storage.azure.container doesn't be updated after specify a custom contianer
Summary: [IPI on Azure]Status.storage.azure.container doesn't be updated after specify...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Corey Daley
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-12 07:05 UTC by XiuJuan Wang
Modified: 2019-10-16 06:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:35:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 378 0 None closed Bug 1740035: Azure should create custom container 2020-08-18 15:28:48 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:35:46 UTC

Description XiuJuan Wang 2019-08-12 07:05:35 UTC
Description of problem:
Status.storage.azure.container doesn't be updated after specify a custom contianer

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-08-10-002649

How reproducible:
always

Steps to Reproduce:
1.Edit Spec.storage.azure.container to a custom one.
$oc patch config.imageregistry cluster -p '{"spec":{"storage":{"azure":{"container":"testtestabcd"}}}}' --type=merge
2.Check container if takes effect.
3.

Actual results:

image registry pod has recreated with new storage container with seveval mins, but Status.storage.azure.container is still old one.

$ oc set env deployment image-registry   --list  | grep  AZURE
REGISTRY_STORAGE_AZURE_CONTAINER=testtestabcd
REGISTRY_STORAGE_AZURE_ACCOUNTNAME=qexiuwang812azurekvhxxj4
$ oc describe  config.imageregistry  | grep Container
      Container:     testtestabcd
    Reason:                ContainerExists
      Container:     qe-xiuwang-812-azure-kvdgw-image-registry-f052ff2abcc211e98ca3

[wxj@dhcp-140-124 kubecon]$ oc describe  config.imageregistry  | grep Container -B4 
      Max Wait In Queue:  0s
  Storage:
    Azure:
      Account Name:  qexiuwang812azurekvhxxj4
      Container:     testtestabcd
--
  Ready Replicas:          0
  Storage:
    Azure:
      Account Name:  qexiuwang812azurekvhxxj4
      Container:     qe-xiuwang-812-azure-kvdgw-image-registry-f052ff2abcc211e98ca3


Expected results:
Should update Status.storage.azure.container as Spec.storage.azure.container 

Additional info:

Comment 1 Corey Daley 2019-08-12 19:58:51 UTC
I see what the issue is, the operator is not currently handling the case of a name being supplied, i'll put together a pull request

Comment 3 XiuJuan Wang 2019-09-11 02:18:58 UTC
Status.storage.azure.container has been updated after specify a custom container

$ oc describe config.image | grep  Container -B4
      Max Wait In Queue:  0s
  Storage:
    Azure:
      Account Name:  qexiuwangazure911j4xt92j
      Container:     qe-xiuwang-azure-911-j4rg2-test
Status:
  Conditions:
    Last Transition Time:  2019-09-11T01:25:20Z
    Message:               Storage container exists
    Reason:                ContainerExists
--
  Ready Replicas:          0
  Storage:
    Azure:
      Account Name:  qexiuwangazure911j4xt92j
      Container:     qe-xiuwang-azure-911-j4rg2-test

Verified with payload 4.2.0-0.nightly-2019-09-10-235718

Comment 4 errata-xmlrpc 2019-10-16 06:35:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.