Bug 1740095 - ALT+TAB might contain hidden infinite loop
Summary: ALT+TAB might contain hidden infinite loop
Keywords:
Status: CLOSED DUPLICATE of bug 1697062
Alias: None
Product: Fedora
Classification: Fedora
Component: xfwm4
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-12 09:49 UTC by klfyt
Modified: 2019-12-08 10:03 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 12:05:54 UTC
Type: Bug


Attachments (Terms of Use)
little graphic (I can't get any closer to the answer - memory allocation? core affinity?) (27.03 KB, image/png)
2019-09-14 12:11 UTC, klfyt
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1839610 0 None None None 2019-08-12 09:51:09 UTC

Description klfyt 2019-08-12 09:49:58 UTC
Description of problem:
Anywhere where you need to travel to previous view
performance drops visibly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. go to previous view
2.
3.

Actual results:
Performance starts to degrade.

Expected results:
Performance is like before.  :))

Additional info:
Documents
Documents/a
Documents    <  performance degrades  (workaround go anywhere else besides
                                       Documents or Documents/.. and only
                                       then go to Documents)

Comment 1 klfyt 2019-08-12 10:18:04 UTC
*** Bug 1729681 has been marked as a duplicate of this bug. ***

Comment 2 klfyt 2019-08-14 09:35:53 UTC
Think the only obvious so-called workaround is avoiding
getting into previous through whatever means possible.

This way you can keep it on the level.  :-)

Simple rule is:
previous view ?  skip to something else  :))

>:]

Comment 3 klfyt 2019-08-14 14:39:35 UTC
*** Bug 1670504 has been marked as a duplicate of this bug. ***

Comment 4 klfyt 2019-08-16 17:08:32 UTC
(In reply to klfyt from comment #2)
> Think the only obvious so-called workaround is avoiding
> getting into previous through whatever means possible.
> 
> This way you can keep it on the level.  :-)
> 
> Simple rule is:
> previous view ?  skip to something else  :))
> 
> >:]


a > b

b == previous?

b > c > b

Comment 5 klfyt 2019-08-28 18:52:39 UTC
Fastest xfmw

alt tab  > shift alt tab > alt tab


Fastest browser (Firefox, Chromium)

shift ctrl tab > ctrl tab

Comment 6 klfyt 2019-08-29 08:05:37 UTC
Fastest text  :-)

navigate left -1 letter keep typing.



For example:

Good m|f
Good morning|f

Good morning.

Comment 7 klfyt 2019-08-29 08:10:14 UTC
*** Bug 1744930 has been marked as a duplicate of this bug. ***

Comment 8 klfyt 2019-08-29 08:10:41 UTC
*** Bug 1724029 has been marked as a duplicate of this bug. ***

Comment 9 klfyt 2019-08-29 08:12:30 UTC
*** Bug 1677161 has been marked as a duplicate of this bug. ***

Comment 10 klfyt 2019-08-29 08:12:56 UTC
*** Bug 1674486 has been marked as a duplicate of this bug. ***

Comment 11 klfyt 2019-08-29 08:13:22 UTC
*** Bug 1733819 has been marked as a duplicate of this bug. ***

Comment 12 klfyt 2019-08-29 08:13:43 UTC
*** Bug 1729666 has been marked as a duplicate of this bug. ***

Comment 13 klfyt 2019-08-29 08:14:06 UTC
*** Bug 1727998 has been marked as a duplicate of this bug. ***

Comment 14 klfyt 2019-08-29 08:14:27 UTC
*** Bug 1740646 has been marked as a duplicate of this bug. ***

Comment 15 klfyt 2019-08-29 08:15:22 UTC
*** Bug 1731759 has been marked as a duplicate of this bug. ***

Comment 16 klfyt 2019-08-29 08:15:42 UTC
*** Bug 1730272 has been marked as a duplicate of this bug. ***

Comment 17 klfyt 2019-08-29 08:16:02 UTC
*** Bug 1726250 has been marked as a duplicate of this bug. ***

Comment 18 klfyt 2019-08-29 08:16:22 UTC
*** Bug 1725831 has been marked as a duplicate of this bug. ***

Comment 19 klfyt 2019-08-29 08:16:55 UTC
*** Bug 1697062 has been marked as a duplicate of this bug. ***

Comment 20 klfyt 2019-08-29 08:17:09 UTC
*** Bug 1738604 has been marked as a duplicate of this bug. ***

Comment 21 klfyt 2019-08-29 08:18:48 UTC
*** Bug 1670504 has been marked as a duplicate of this bug. ***

Comment 22 klfyt 2019-08-29 08:19:26 UTC
*** Bug 1677547 has been marked as a duplicate of this bug. ***

Comment 23 klfyt 2019-08-29 08:19:47 UTC
*** Bug 1683074 has been marked as a duplicate of this bug. ***

Comment 24 klfyt 2019-08-29 08:20:16 UTC
*** Bug 1684757 has been marked as a duplicate of this bug. ***

Comment 25 klfyt 2019-08-29 08:20:46 UTC
*** Bug 1725310 has been marked as a duplicate of this bug. ***

Comment 26 klfyt 2019-08-29 08:21:36 UTC
*** Bug 1693960 has been marked as a duplicate of this bug. ***

Comment 27 klfyt 2019-08-29 08:22:27 UTC
*** Bug 1726553 has been marked as a duplicate of this bug. ***

Comment 28 klfyt 2019-09-01 18:08:36 UTC
Magic combo is previous + next for a view. Affected: Firefox, Chromium, Thunar >:].

  :))

Comment 29 klfyt 2019-09-06 11:31:14 UTC
Hi. Maybe it resets list of arrays, but I don't know
which array?

:))

Comment 30 klfyt 2019-09-14 09:54:15 UTC
(In reply to klfyt from comment #28)
> Magic combo is previous + next for a view. Affected: Firefox, Chromium,
> Thunar >:].
> 
>   :))

previous + previous is even faster

as is typing text if you keep two empty [  ] spaces before text, example "text__"  

:))

Comment 31 klfyt 2019-09-14 12:11:59 UTC
Created attachment 1615120 [details]
little graphic (I can't get any closer to the answer - memory allocation? core affinity?)

Comment 32 klfyt 2019-09-17 13:56:47 UTC
(In reply to klfyt from comment #31)
> Created attachment 1615120 [details]
> little graphic (I can't get any closer to the answer - memory allocation?
> core affinity?)

https://bugzilla.redhat.com/show_bug.cgi?id=1744930
This seems to improve latency.

Comment 33 klfyt 2019-09-21 09:51:23 UTC
Scrolling is also affected by NumPad and CapsLock,
if you turn both of them on then scrolling is 
faster than turning either of them on.


NUMPAD + CAPSLOCK -> FASTER THAN CAPSCLOCK

NUMPAD + CAPSLOCK -> FASTER THAN NUMPAD



>:]

Comment 34 klfyt 2019-09-23 15:18:03 UTC
(In reply to klfyt from comment #33)
> Scrolling is also affected by NumPad and CapsLock,
> if you turn both of them on then scrolling is 
> faster than turning either of them on.
> 
> 
> NUMPAD + CAPSLOCK -> FASTER THAN CAPSCLOCK
> 
> NUMPAD + CAPSLOCK -> FASTER THAN NUMPAD
> 
> 
> 
> >:]

https://bugzilla.redhat.com/show_bug.cgi?id=1754300

delete numbers from url

Comment 35 klfyt 2019-10-06 09:56:20 UTC
Maybe ALT+TAB is broken here also.
Use SHIFT+ALT+TAB instead.

ALT+TAB (shiftalttab is faster), two spaces in url (fixes scrolling issues).

Comment 36 klfyt 2019-10-10 12:05:54 UTC

*** This bug has been marked as a duplicate of bug 1697062 ***

Comment 37 klfyt_ 2019-12-08 10:02:35 UTC
This is interesting bug, moderator can you mark this as individual bug report not duplicate?

a b [c] d e

if b is previous and you have to switch to it then
you can use c > a > b

c > b is not allowed.



:))

infinite loop in url   https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1839716

Comment 38 klfyt_ 2019-12-08 10:03:48 UTC
(In reply to klfyt_ from comment #37)
> This is interesting bug, moderator can you mark this as individual bug
> report not duplicate?
> 
> a b [c] d e
> 
> if b is previous and you have to switch to it then
> you can use c > a > b
> 
> c > b is not allowed.
> 
> 
> 
> :))
> 
> infinite loop in url  
> https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1839716


I am also suspecting ALT-TAB might be broken whereas SHIFT-ALT-TAB isn't.


Note You need to log in before you can comment on or make changes to this bug.