Bug 1740122 - foomatic-rip segfaults when env variable PRINTER is not defined
Summary: foomatic-rip segfaults when env variable PRINTER is not defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups-filters
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1709338 (view as bug list)
Depends On:
Blocks: 1740271
TreeView+ depends on / blocked
 
Reported: 2019-08-12 10:21 UTC by Martin Sehnoutka
Modified: 2019-09-06 05:38 UTC (History)
2 users (show)

Fixed In Version: cups-filters-1.22.5-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1740271 (view as bug list)
Environment:
Last Closed: 2019-08-22 01:17:08 UTC
Type: Bug


Attachments (Terms of Use)
file /var/spool/cups (660.55 KB, application/pdf)
2019-08-12 10:21 UTC, Martin Sehnoutka
no flags Details
pdftopdf output (652.83 KB, application/pdf)
2019-08-12 10:21 UTC, Martin Sehnoutka
no flags Details
ppd file (13.32 KB, text/plain)
2019-08-12 10:23 UTC, Martin Sehnoutka
no flags Details
page that fails to print (109.75 KB, application/pdf)
2019-08-12 10:38 UTC, Martin Sehnoutka
no flags Details
journal output from cups with JID specified (20.28 KB, text/plain)
2019-08-12 12:44 UTC, Martin Sehnoutka
no flags Details

Description Martin Sehnoutka 2019-08-12 10:21:10 UTC
Created attachment 1602875 [details]
file /var/spool/cups

Description of problem:

I was debugging printing of a specific pdf file. I tried to create a file-device print queue and the output of printing was in postscript format, but ghostscript crashed when I attempted to open the file. So I tried to run filters by hand. pdftopdf was fine, but foomatic-rip crashed with segmentation fault. See the output below:

$ /usr/lib/cups/filter/foomatic-rip 4 msehnout '' 1 '' /tmp/out.pdf > out2.ps
DEBUG: Color Manager: Invalid printer name.
'CM Color Calibration' Mode in SPOOLER-LESS: Off
Getting input from file /tmp/out.pdf
Segmentation fault (core dumped)

Version-Release number of selected component (if applicable):
$ rpm -q cups-filters
cups-filters-1.22.5-1.fc30.x86_64

Comment 1 Martin Sehnoutka 2019-08-12 10:21:45 UTC
Created attachment 1602876 [details]
pdftopdf output

Comment 2 Martin Sehnoutka 2019-08-12 10:23:24 UTC
Created attachment 1602877 [details]
ppd file

Comment 3 Martin Sehnoutka 2019-08-12 10:38:24 UTC
Created attachment 1602884 [details]
page that fails to print

Comment 4 Martin Sehnoutka 2019-08-12 12:44:18 UTC
Created attachment 1602930 [details]
journal output from cups with JID specified

Comment 5 Zdenek Dohnal 2019-08-12 13:57:06 UTC
Segfault was caused by covscan fix, pull request is here https://github.com/OpenPrinting/cups-filters/pull/139 .

No printing is other issue, investigating more...

Comment 6 Zdenek Dohnal 2019-08-13 06:54:34 UTC
Upstream accepted patch, I'll build the new package.

Comment 7 Fedora Update System 2019-08-13 07:41:39 UTC
FEDORA-2019-a3c6e450ef has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a3c6e450ef

Comment 8 Ben Cotton 2019-08-13 17:03:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 9 Fedora Update System 2019-08-14 01:36:22 UTC
cups-filters-1.22.5-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a3c6e450ef

Comment 10 Fedora Update System 2019-08-22 01:17:08 UTC
cups-filters-1.22.5-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Zdenek Dohnal 2019-09-06 05:38:39 UTC
*** Bug 1709338 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.